Вопрос задан 11.05.2019 в 18:24. Предмет Информатика. Спрашивает Житникова Юлия.

Написать программу на Pacal задачи: 1.Дано два ненулевых числа проверить истинность высказывания

"числа имеют разные знаки". 2. Дано два целых числа проверить истинность высказывания " оба числа четные".
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Черноблавская Мария.
1.
var a,b:integer;
begin
readln(a);
readln(b);
if ((a>0) and (b>0)) Or ((a<0) and (b<0)) 
writeln('У обоих чисел одинаковые знаки')
else
writeln('У чисел разные знаки') ;
end.
2.
var a,b:integer;
begin
readln(a);
readln(b);
if (a mod 2=0) And (b mod 2=0) then
writeln('Высказывание истинно')
else
writeln('Высказывание ложно') 
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Pascal для решения задачи 1:

```pascal program CheckSigns;

var num1, num2: integer; result: boolean;

begin writeln('Введите первое число:'); readln(num1); writeln('Введите второе число:'); readln(num2); result := (num1 < 0) and (num2 > 0) or (num1 > 0) and (num2 < 0); writeln('Результат: ', result); readln; end. ```

Программа на Pascal для решения задачи 2:

```pascal program CheckEvenNumbers;

var num1, num2: integer; result: boolean;

begin writeln('Введите первое число:'); readln(num1); writeln('Введите второе число:'); readln(num2); result := (num1 mod 2 = 0) and (num2 mod 2 = 0); writeln('Результат: ', result); readln; end. ```

Обе программы принимают ввод от пользователя для двух чисел и проверяют истинность соответствующего высказывания. Затем результат выводится на экран. В первой программе используется оператор `and` для проверки, что одно число отрицательное, а другое положительное. Во второй программе используется оператор `mod` для проверки, что оба числа являются четными.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос