
Составьте программу на языке Паскаль: Найти сумму цифр трёхзначного числа.


Ответы на вопрос

begin
s:=0;
readln (n);
a1:=a div 100;
a2:= a div 10 mod 10;
a3:=a mod 10;
s:=a1+a2+a3;
write (s);
end.



Программа на языке Паскаль для нахождения суммы цифр трехзначного числа будет выглядеть следующим образом:
```pascal program SumOfDigits; var number, digit1, digit2, digit3, sum: integer; begin writeln('Введите трехзначное число: '); readln(number);
// Разбиваем число на отдельные цифры digit1 := number div 100; digit2 := (number div 10) mod 10; digit3 := number mod 10;
// Находим сумму цифр sum := digit1 + digit2 + digit3;
writeln('Сумма цифр трехзначного числа ', number, ' равна ', sum); end. ```
В данной программе пользователь сначала вводит трехзначное число. Затем число разбивается на отдельные цифры с помощью операций деления нацело и взятия остатка от деления. После этого происходит вычисление суммы цифр трехзначного числа и выводится на экран.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili