Срочно!!! Помогите!!!!!! Составьте программу, для подсчета дней, месяцев с температурой 15градусов,
массив в программе сформировать с помощью клавиатуры. Pasckal ABC.Ответы на вопрос
const
handsfree = false;
nmax = 31;
random_min = -20;
random_max = 30;
var
a: array[1..nmax] of real;
i, n, j: integer;
k: integer;
begin
{ввод массива}
if handsfree then
n := random(nmax - 5) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(random_max - random_min) + random_min;
write(a[i], ' ');
end
else
readln(a[i]);
end;
writeln();
{подсчет элементов}
k := 0;
for i := 1 to n do
if a[i] = 15 then
k := k + 1;
writeln('quantity = ', k);
end.
Конечно, я могу помочь вам составить программу для подсчета дней и месяцев с температурой 15 градусов на языке Pascal.
Вот пример программы, которая будет запрашивать у пользователя количество дней и температуру каждого дня, а затем подсчитывать количество дней и месяцев, когда температура была равна 15 градусам:
``` program countDays;
type TemperatureArray = array [1..31] of integer;
var days, months, i: integer; temperature: TemperatureArray;
begin days := 0; months := 0;
writeln('Введите количество дней:'); readln(days);
writeln('Введите температуру каждого дня:');
for i := 1 to days do begin write('День ', i, ': '); readln(temperature[i]);
if temperature[i] = 15 then begin days := days + 1; if days mod 31 = 0 then months := months + 1; end; end;
writeln('Количество дней с температурой 15 градусов: ', days); writeln('Количество месяцев с температурой 15 градусов: ', months); end. ```
В программе определяется тип `TemperatureArray`, который представляет массив с температурами для каждого дня. Количество дней задается пользователем, после чего происходит ввод температуры для каждого дня. Затем происходит проверка, равна ли температура 15 градусам. Если да, то переменная `days` увеличивается на 1, а если количество дней становится кратным 31, то переменная `months` увеличивается на 1. В конце программы выводится количество дней и месяцев с температурой 15 градусов.
Пожалуйста, обратите внимание, что код введен в формате Pascal.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
