Вопрос задан 18.02.2019 в 16:00. Предмет Информатика. Спрашивает Гончарова Алена.

Составьте программу выводящую на экран большее из 5 чисел Программа из Кумира

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Финапетов Максим.
Сделал через массив

program Project2; 
{$APPTYPE CONSOLE}
uses  SysUtils;
const n=4;
var a:array [0..n] of integer;max,i:Integer;
begin 
for i:=0 to n do 
 readln(a[i]); 
min:=a[0];
 for i:=0 to n do 
if a[i]>max then   
max:=a[i]; 
Writeln(max); 
readln;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Код программы на Кумире для вывода на экран большего из 5 чисел

Для создания программы на Кумире, которая будет выводить на экран большее из 5 чисел, можно использовать следующий код:

```kumir var a, b, c, d, e: integer;

begin read(a, b, c, d, e); if (a > b) and (a > c) and (a > d) and (a > e) then write(a) else if (b > c) and (b > d) and (b > e) then write(b) else if (c > d) and (c > e) then write(c) else if (d > e) then write(d) else write(e); end. ```

Этот код объявляет 5 переменных (a, b, c, d, e), считывает их значения и затем сравнивает их, чтобы определить наибольшее из них. После этого на экран выводится наибольшее число.

Примечание: Пожалуйста, убедитесь, что вы используете среду программирования Кумир для запуска этой программы.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос