Напишите программу на паскале, которая будет определять время суток по введенным часам
Ответы на вопрос
Я могу помочь вам с вашим запросом. Вот один из возможных вариантов программы на паскале, которая определяет время суток по введенным часам:
``` program TimeOfDay; var hour: integer; begin writeln('Введите час от 0 до 23'); readln(hour); if (hour < 0) or (hour > 23) then writeln('Неверный ввод') else case hour of 0..5: writeln('Ночь'); 6..11: writeln('Утро'); 12..17: writeln('День'); 18..23: writeln('Вечер'); end; end. ```
Эта программа использует оператор case для проверки введенного часа и выводит соответствующее время суток. Если введенное значение не является допустимым часом, программа сообщает об ошибке. Вы можете найти другие примеры программ на паскале в интернете, например [здесь](https://www.cyberforum.ru/free-pascal/thread1967654.html) или [здесь](https://online-otvet.ru/informatika/5cea9cae96f4e19a2951cf01). Надеюсь, это было полезно для вас. Спасибо за использование Bing.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
