
Написать программу которая запросит длинны трёх сторон треугольника. Проверить возможность его сущ.
и в предположенном результате найдёт и выведет на экран площадь один. Ребята!!!! Спасайте кто может!!!!!

Ответы на вопрос

a,b,c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;
begin
writeln('Введите стороны треугольника:');
readln(a,b,c);
if (a>=b+c) or (b>=a+c) or (c>=a+b) then
writeln ('Такого треугольника не существует')
else begin
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c)); {вычисляем S тр. по формуле Герона}
writeln ('Такой треугольник существует, его S = ', S, 'ед.');
end;
end.



Конечно, я помогу вам с написанием программы для вычисления площади треугольника.
Вот пример кода на языке Python:
```python import math
# Запрос длин сторон треугольника a = float(input("Введите длину первой стороны треугольника: ")) b = float(input("Введите длину второй стороны треугольника: ")) c = float(input("Введите длину третьей стороны треугольника: "))
# Проверка возможности существования треугольника if a + b > c and a + c > b and b + c > a: # Вычисление полупериметра p = (a + b + c) / 2 # Вычисление площади s = math.sqrt(p * (p - a) * (p - b) * (p - c)) print("Площадь треугольника равна:", s) else: print("Треугольник с такими сторонами не существует.") ```
Программа сначала запрашивает у пользователя длины трех сторон треугольника. Затем она проверяет условие существования треугольника: сумма длин двух сторон всегда должна быть больше длины третьей стороны. Если условие выполняется, программа вычисляет полупериметр треугольника и площадь с помощью формулы Герона. Результат выводится на экран.
Надеюсь, эта программа поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili