Вопрос задан 19.09.2018 в 02:00. Предмет Информатика. Спрашивает Богданов Богдан.

Составить программу вычисления скорости из км/ч в м/с в программе абс паскаль

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Солопатич Іван.
Program n1;
var a: real;
begin
write('введите скорость в км/ч: ');
readln(a);
write('эта скорость в м/с: ',a*5/18);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конвертация скорости из километров в час в метры в секунду осуществляется путем деления значения в километрах в час на 3.6 (так как 1 км/ч = 1/3.6 м/с). Программа на языке программирования Pascal для этой конвертации может выглядеть следующим образом:

```pascal program ConvertSpeed;

var speedInKmPerHour, speedInMPerSec: real;

begin // Вводим скорость в километрах в час write('Введите скорость в км/ч: '); readln(speedInKmPerHour);

// Вычисляем скорость в метрах в секунду speedInMPerSec := speedInKmPerHour / 3.6;

// Выводим результат writeln('Скорость в м/с: ', speedInMPerSec:0:2); end. ```

В этой программе используется переменная `speedInKmPerHour` для ввода скорости в километрах в час. Затем она делится на 3.6 и результат сохраняется в переменной `speedInMPerSec`. Наконец, программа выводит скорость в метрах в секунду с точностью до двух знаков после запятой.

Вы можете скопировать этот код в среду программирования Pascal (например, Lazarus) и выполнить программу, чтобы увидеть, как она работает.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос