СРОЧНО! Напишите программу на языке Паскаль для решения задачи: Дан целочисленный одномерный
массив, состоящий из n элементов. Найти количество элементов, которые кратны 4. На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!Ответы на вопрос
Ответ:
program z;
var m:array[1..32767] of integer;
n,i,k:integer;
begin
randomize;
k:=0;
read(n);
for i:=1 to n do
begin
m[i]:=random(20)+1;
if m[i] mod 4 = 0 then k:=k+1;
write(m[i],' ')
end;
writeln;
write(k)
end.
скрин
Объяснение:
для проверки кратности используем операцию mod (остаток от целочисленного деления)
в программе используем циклс параметром (for i:=1 to n do) и условный оператор (if m[i] mod 4 = 0 then k:=k+1;)

Пример программы на языке Паскаль, решающей данную задачу:
```pascal program CountMultiplesOf4;
const n = 10; // задаем размер массива var arr: array[1..n] of integer; // объявляем массив i, count: integer; begin // инициализируем массив случайными значениями Randomize; for i := 1 to n do arr[i] := Random(100); // генерация случайного числа от 0 до 99 // выводим элементы массива writeln('Исходный массив:'); for i := 1 to n do write(arr[i], ' '); writeln; // находим количество элементов, кратных 4 count := 0; for i := 1 to n do if arr[i] mod 4 = 0 then Inc(count); // выводим результат writeln('Количество элементов, кратных 4: ', count); end. ```
В данной программе мы создаем одномерный массив `arr` размером `n`, инициализируем его случайными значениями от 0 до 99 и выводим элементы массива на экран. Затем проходим по всем элементам массива и проверяем, кратен ли каждый элемент числу 4. Если да, то увеличиваем счетчик `count`. По завершении цикла выводим значение счетчика на экран.
Пример работы программы: ``` Исходный массив: 36 88 79 60 5 58 82 87 34 60 Количество элементов, кратных 4: 4 ```
Как следует из примера, в данном случае в массиве `arr` есть 4 элемента, которые кратны 4.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
