 
Написать программу для Pascal Abc, решающую следующую задачу: дано трёхзначное число. Вывести
число, полученное при перестановке крайних чисел исходного числа 0
        0
         0
        0
    Ответы на вопрос
 
        var x:integer;
a1,a2,a3:integer;
begin
write('x=');readln(x);
a1:=x div 100;
a2:=(x div 10) mod 10;
a3:=x mod 10;
x:=a3*100+a2*10+a1;
writeln(x);
readln
end.
 0
                    0
                     0
                    0
                 
            Программа на Pascal ABC:
```pascal program Permutation; var number, firstDigit, lastDigit, newNumber: integer; begin writeln('Введите трехзначное число: '); readln(number); if (number < 100) or (number > 999) then begin writeln('Введено неверное число'); end else begin firstDigit := number div 100; lastDigit := number mod 10; newNumber := lastDigit * 100 + (number mod 100) - lastDigit + firstDigit; writeln('Число после перестановки крайних цифр: ', newNumber); end; end. ```
Эта программа сначала запрашивает у пользователя трехзначное число. Затем программа проверяет, что введенное число действительно трехзначное. Если это так, то программа вычисляет первую и последнюю цифры введенного числа, затем меняет их местами и выводит полученное число. Если же введенное число не является трехзначным, то программа выведет сообщение о неверном вводе.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			