Вопрос задан 13.11.2023 в 13:00. Предмет Информатика. Спрашивает Бойко Ксения.

Цикл FOR 4. Напишите программу, которая в последовательности целых чисел определяет минимальное

число, кратное 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мишкин Всеволод.

Array = []

el = int(input())

Array.append(el)

minn = 30001

while el != 0:

   el = int(input())

   Array.append(el)

Array.remove(0)

for i in range(len(Array)):

   if (Array[i] % 5 == 0 or Array[i] % 9 == 0) and Array[i] < minn:

       minn = Array[i]

print(minn)


0 0
Отвечает Орлова Арина.

arr = []

n = True

while n != 0:

   n = int(input())

   if n%5 == 0 and n%9 == 0 and n != 0:

       arr.append(n)

print(min(arr))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи, можно использовать цикл `for` в языке программирования Python. Вот пример программы, которая находит минимальное число, кратное 5 или 9, в последовательности целых чисел:

```python min_multiple = float('inf') # Инициализация переменной с бесконечно большим значением

while True: num = int(input("Введите число (0 для завершения): ")) if num == 0: break if num % 5 == 0 or num % 9 == 0: min_multiple = min(min_multiple, num)

if min_multiple != float('inf'): print("Минимальное число, кратное 5 или 9:", min_multiple) else: print("В последовательности нет чисел, кратных 5 или 9.") ```

Эта программа запрашивает у пользователя числа до тех пор, пока не будет введено число 0. Затем она проверяет каждое введенное число на кратность 5 или 9 и обновляет значение `min_multiple`, если текущее число меньше текущего минимального значения. В конце программа выводит найденное минимальное число, кратное 5 или 9, или сообщает, что в последовательности нет таких чисел.

Примечание: В данном примере используется функция `input()` для ввода чисел с клавиатуры. Если вы хотите использовать заранее заданную последовательность чисел, вы можете изменить программу соответствующим образом.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос