Вопрос задан 10.07.2023 в 16:30.
Предмет Информатика.
Спрашивает Евтеев Александр.
Паскаль 1) Напишите программу, которая в последовательности целых чисел определяет количество
чисел, кратных 4 или 7. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 4 или 7. 2) Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 6. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех двузначных чисел, кратных 6.Ответы на вопрос
Отвечает Черепанов Сергей.
===== PascalABC.NET =====
= 1 =
begin
ReadSeqIntegerWhile(p -> p <> 0)
.Count(p -> (p mod 4 = 0) or (p mod 7 = 0))
end.
= 2 =
begin
ReadSeqIntegerWhile(p -> p <> 0)
.Where(p -> (p mod 6 = 0) and p.InRange(10, 99))
.Sum
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Паскаль для решения первой задачи (определение количества чисел, кратных 4 или 7):
pascalprogram CountMultiples; var num, count: integer; begin count := 0; repeat read(num); if (num = 0) then break; if (num mod 4 = 0) or (num mod 7 = 0) then count := count + 1; until false; writeln(count); end.
Программа на языке Паскаль для решения второй задачи (вычисление суммы всех двузначных чисел, кратных 6):
pascalprogram SumMultiples; var num, sum: integer; begin sum := 0; repeat read(num); if (num = 0) then break; if (num >= 10) and (num <= 99) and (num mod 6 = 0) then sum := sum + num; until false; writeln(sum); end.
Обратите внимание, что обе программы используют оператор repeat...until false для ввода чисел до тех пор, пока не будет введено число 0 (признак окончания ввода). Затем они проверяют условия для определения кратности и соответственно увеличивают счетчик или сумму.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 624
Информатика 47
Информатика 30
Информатика 39
Информатика 1833
Информатика 1335
Информатика 136
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
