Вопрос задан 07.11.2023 в 06:09. Предмет Информатика. Спрашивает Петров Денис.

Меньше среднего.C++ Дан массив A из N элементов. Требуется найти и вывести количество элементов,

значение которых меньше среднего арифметического значения элементов массива. Input Со стандартного устройства ввода в первой строке вводится целое число N (1 <= N <=1000) — количество элементов массива. Во второй строке через пробел вводятся N целых чисел - элементы массива A (-1000 <= A i <= 1000). Output Требуется вывести целое число - количество искомых элементов. Выводить в конце строки пробел не нужно. Sample Input 5 2 4 6 10 8 Sample Output 2 Примечание Среднеe арифметическое значение элементов массива = (Сумма значений всех элементов массива) / (Количество элементов в массиве). В примере среднеe арифметическое значение = (2 + 4 + 6 + 10 + 8) / 5 = 6.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Брежнев Ваня.

#include <iostream>

using namespace std;

int main() {

   int N;

   cin >> N;

   int* arr = new int[N];

   int sum = 0;

   for (int i = 1; i <= N; ++i) {

       cin >> arr[i - 1];

       sum += arr[i - 1];

   }

   int count = 0;

   for (int i = 0; i < N; ++i) {

       if (arr[i] < (sum / N))

           ++count;

   }

   cout << count;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам потребуется написать программу, которая считывает входные данные, находит среднее арифметическое элементов массива и затем считает количество элементов, значение которых меньше этого среднего значения. Вот подробный код на языке C++:

```cpp #include using namespace std;

int main() { int N; cin >> N; // Считываем количество элементов массива

int A[N]; int sum = 0;

// Считываем элементы массива и суммируем их for (int i = 0; i < N; i++) { cin >> A[i]; sum += A[i]; }

// Вычисляем среднее арифметическое int average = sum / N;

int count = 0;

// Считаем количество элементов, меньших среднего for (int i = 0; i < N; i++) { if (A[i] < average) { count++; } }

// Выводим результат cout << count << endl;

return 0; } ```

Пример ввода и вывода:

Sample Input: ``` 5 2 4 6 10 8 ```

Sample Output: ``` 2 ```

Программа сначала считывает количество элементов массива (N), затем сам массив (A). Затем она вычисляет сумму всех элементов массива и среднее арифметическое значение. Далее она проходит по элементам массива и считает количество элементов, значение которых меньше среднего арифметического. Наконец, программа выводит это количество.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос