Вопрос задан 31.10.2023 в 03:15. Предмет Информатика. Спрашивает Угарова Аня.

Помогите с информатикой. Напишите программу на Паскале. Дано натуральное число n (n  9999). Если

число четырёхзначное, то получите и выведите перевёртыш этого числа (3528 → 8253), иначе выведите ответ "Число не четырехзначное". Даю 50 баллов.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смирнов Кирилл.

Решение на фото, думаю, что так


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Паскале, которая выполняет требуемые действия:

```pascal program ReverseNumber;

var n, reversed: Integer;

begin // Ввод числа Write('Введите число (n ≤ 9999): '); Readln(n); // Проверка на четырехзначность числа if (n >= 1000) and (n <= 9999) then begin // Получение перевернутого числа reversed := (n mod 10) * 1000 + ((n div 10) mod 10) * 100 + ((n div 100) mod 10) * 10 + n div 1000; // Вывод перевернутого числа Writeln('Перевернутое число:', reversed); end else begin // Вывод сообщения, если число не четырехзначное Writeln('Число не четырехзначное'); end; end. ```

Программа сначала запрашивает у пользователя ввод числа `n`. Затем она проверяет, является ли число четырехзначным. Если да, то она переворачивает число, используя остатки и целочисленное деление. Наконец, она выводит полученный перевернутый результат. Если число не четырехзначное, программа выводит сообщение об ошибке.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос