Вопрос задан 27.10.2023 в 21:03. Предмет Информатика. Спрашивает Семеняга Илья.

Написать программу, которая водит натуральные числа от до и выводит все простые числа в диапазоне

от до . На Python пожалуйста!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Московка София.

def print_primes(low_number, high_number):

   for number in range(low_number, high_number + 1):

       if number > 1:

           for i in range(2, number):

               if number % i == 0:

                   break

           else:

               print(number)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая выводит все простые числа в заданном диапазоне:

```python def is_prime(num): if num < 2: return False for i in range(2, int(num**0.5) + 1): if num % i == 0: return False return True

start = int(input("Введите начало диапазона: ")) end = int(input("Введите конец диапазона: "))

print("Простые числа в диапазоне от", start, "до", end, "суть:") for num in range(start, end + 1): if is_prime(num): print(num) ```

В этой программе определена функция `is_prime()`, которая проверяет, является ли число простым. Затем пользователю предлагается ввести начало и конец диапазона. Программа затем перебирает все числа в этом диапазоне и выводит только простые числа.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос