Вопрос задан 12.07.2023 в 23:26. Предмет Информатика. Спрашивает Тупиков Сергей.

1) Вводятся два целых числа. Программа выводит наибольшее и наименьшее из них. Пример: Введите

два целых числа: 1 5 Наибольшее число 5 Наименьшее число 1 2) Вводятся четыре целых числа. Программа выводит наибольшее из них. Пример: Введите четыре целых числа: 1 5 4 3 Наибольшее число 5 3)Вводится последовательно возраст Антона, Бориса и Виктора. Программа выводит, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех. Пример: Возраст Антона: 17 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Антон и Борис старше Виктора. 4)апишите программу, которая получает три числа - рост трёх спортсменов, и выводит сообщение «По росту», если они стоят по возрастанию роста, или сообщение «Не по росту», если они стоят не по росту. Пример: Введите рост трёх спортсменов: 165 170 172 По росту. Пример: Введите рост трёх спортсменов: 175 170 172 Не по росту! 5) Напишите программу, которая получает номер месяца и выводит соответствующее ему время года или сообщение об ошибке. Пример: Введите номер месяца: 5 Весна. Пример: Введите номер месяца: 15 Неверный номер месяца. 6) Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом «год», «года» или «лет». Например, «21 год», «22 года», «25 лет». Пример: Введите возраст: 18 Вам 18 лет. Пример: Введите возраст: 21 Вам 21 год. Пример: Введите возраст: 22 Вам 22 года. Все на Python! Помогите пожалуйста! Код должен быть простым!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Alisheri Inessa.

1)

number_list = [int(input()) for n in range(2)]

print('наибольшее число: ' + str(max(number_list)))

print('наименьшее число: ' + str(min(number_list)))

2)

number_list = []

for n in range(4):

   number_list.append(int(input()))

print('наибольшее число: ' + str(max(number_list)))

3)

age_list = []

a = age_list.append(int(input('возраст Антона: ')))

b = age_list.append(int(input('возраст Бориса: ')))

v = age_list.append(int(input('возраст Виктора: ')))

if age_list[2] > age_list[1] and age_list[2] > age_list[0]:

   print('Виктор старше всех .')

elif age_list[1] > age_list[2] and age_list[1] > age_list[0]:

   print('Борис старше всех .')

elif age_list[0] > age_list[1] and age_list[0] > age_list[2]:

   print('Антон старше всех .')

elif age_list[0] == age_list[1] and age_list[0] > age_list[2]:

   print('Борис и Антон старше всех .')

elif age_list[0] == age_list[2] and age_list[0] > age_list[1]:

   print('Антон и Виктор старше Бориса .')

elif age_list[1] == age_list[2] and age_list[1] > age_list[0]:

   print('Борис и Виктор старше Антона')

4)

print('Введите возраст трёх спортсменов: ')

number_list = [int(input()) for n in range(3)]

start_list = [i for i in number_list]

number_list.sort()

if number_list == start_list:

   print('По росту .')

else:

   print('не по росту .')

5)

month_ask = str(input('номер месяца: '))

if month_ask not in ['1', '2', '3', '4', '5', '6', '7', '8', '9', '10', '11',

'12', '01', '02', '03', '04', '05', '06', '07', '08', '09']:

   print('неверный номер месяца .')

if month_ask in ['12', '1', '2', '01', '02']:

   print('зима .')

elif month_ask in ['3', '4', '5', '03', '04', '05']:

   print('весна .')

elif month_ask in ['6', '7', '8', '06', '07', '08']:

   print('лето .')

elif month_ask in ['9', '10', '11', '09']:

   print('осень .')

6)

age = str(input('возраст: '))

if age[-1] == '0':

   print('вам %s' % age + ' лет .')

elif len(age) == 2 and age[-1] == '1' and age[0] == '1':

   print('вам %s' % age + ' лет .')

elif age[-1] == '1':

   print('вам %s' % age + ' год .')

elif age[-1] == '2' and age[0] != '1':

   print('вам %s' % age + ' года .')

elif age[-1] == '2' and age[0] == '1':

   print('вам %s' % age + ' лет .')

elif age[-1] == '3' and age[0] == '1':

   print('вам %s' % age + ' лет .')

elif age[-1] == '3' and age[0] != '1':

   print('вам %s' % age + ' года .')

elif age[-1] == '4' and age[0] == '1':

   print('вам %s' % age + ' лет .')

elif age[-1] == '4' and age[0] != '1':

   print('вам %s' % age + ' года .')

elif age[-1] == '5':

   print('вам %s' % age + ' лет .')

elif age[-1] == '6':

   print('вам %s' % age + ' лет .')

elif age[-1] == '7':

   print('вам %s' % age + ' лет .')

elif age[-1] == '8':

   print('вам %s' % age + ' лет .')

elif age[-1] == '9':

   print('вам %s' % age + ' лет .')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, помогу! Вот простые программы на языке Python для каждой из задач:

  1. Вывод наибольшего и наименьшего чисел из двух:
python
def find_max_min(): num1 = int(input("Введите первое целое число: ")) num2 = int(input("Введите второе целое число: ")) maximum = max(num1, num2) minimum = min(num1, num2) print(f"Наибольшее число: {maximum}") print(f"Наименьшее число: {minimum}") find_max_min()
  1. Вывод наибольшего числа из четырех:
python
def find_max(): numbers = [int(x) for x in input("Введите четыре целых числа через пробел: ").split()] maximum = max(numbers) print(f"Наибольшее число: {maximum}") find_max()
  1. Определение старшего из трех:
python
def find_oldest(): age_anton = int(input("Возраст Антона: ")) age_boris = int(input("Возраст Бориса: ")) age_viktor = int(input("Возраст Виктора: ")) if age_anton > age_boris and age_anton > age_viktor: print("Антон старше всех.") elif age_boris > age_anton and age_boris > age_viktor: print("Борис старше всех.") elif age_viktor > age_anton and age_viktor > age_boris: print("Виктор старше всех.") else: print("Антон, Борис и Виктор одного возраста.") find_oldest()
  1. Проверка по росту:
python
def check_height_order(): heights = [int(x) for x in input("Введите рост трех спортсменов через пробел: ").split()] if heights == sorted(heights): print("По росту.") else: print("Не по росту!") check_height_order()
  1. Определение времени года:
python
def get_season(): month = int(input("Введите номер месяца: ")) if 1 <= month <= 2 or month == 12: season = "Зима" elif 3 <= month <= 5: season = "Весна" elif 6 <= month <= 8: season = "Лето" elif 9 <= month <= 11: season = "Осень" else: print("Неверный номер месяца.") return print(season) get_season()
  1. Определение возраста с правильным окончанием:
python
def print_age_with_suffix(): age = int(input("Введите возраст: ")) if age % 10 == 1 and age % 100 != 11: suffix = "год" elif 2 <= age % 10 <= 4 and not 12 <= age % 100 <= 14: suffix = "года" else: suffix = "лет" print(f"Вам {age} {suffix}.") print_age_with_suffix()

Эти программы предназначены для работы в консоли. Просто скопируйте каждую из функций в вашу среду разработки Python и запустите программу. Она попросит вас ввести соответствующие значения, и вы увидите результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос