Вопрос задан 26.10.2023 в 18:44. Предмет Информатика. Спрашивает Король Сережа.

ПОМОГИТЕ с написанием программы в Pascal. Напишите программу, которая в последовательности

натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 5.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бугаева Анна.
Var
  n, sum, i, a: integer;
begin
  read(n);
  sum = 0;
  for i := 1 to n do
  begin
    read(a);
    if (a mod 5 = 0) then
      sum := sum + a;
  end;
  write(sum);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Pascal, которая выполняет указанные вами задачи:

pascal
program SumOfMultiplesOfFive; var n, i, number, sum: integer; begin sum := 0; writeln('Введите количество чисел в последовательности: '); readln(n); writeln('Введите числа: '); for i := 1 to n do begin readln(number); if (number mod 5 = 0) then sum := sum + number; end; writeln('Сумма чисел, кратных 5, равна: ', sum); end.

Программа запрашивает у пользователя количество чисел в последовательности, а затем просит ввести сами числа. Она затем проверяет каждое число на кратность 5 и добавляет его к общей сумме. Наконец, программа выводит сумму чисел, кратных 5.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос