PASCAL 1. Напишите программу, которая в последовательности натуральных чисел определяет сумму
чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел, кратных 5. 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — минимальное число, оканчивающееся на 4.Ответы на вопрос
Ответ:
Всё напишу в объяснении.
Объяснение:
1) Program Ex1;
var
n, a, i, sum : integer;
begin
sum := 0; // обнуляем счетчик суммирования
read(n); // вводим кол-во чисел
for i := 0 to n do
begin
read(a); // считываем эти числа
if (a mod 5 = 0) then sum := sum + a; // если число кратно 5, то добавляем его к сумме
end;
writeln(sum); // выводим сумму.
end.
2) Program Ex2;
var
n, a, i, min: integer;
begin
min := 30000;
read(n); // вводим кол-во чисел
for i := 0 to n do
begin
read(a); // считываем эти числа
if ((a mod 10 = 4) and (a < min)) then min := a; // ищем минимум
end;
writeln(min); // выводим минимум
end.
Программа на языке Pascal для нахождения суммы чисел, кратных 5, в последовательности:
pascalprogram SumOfMultiplesOfFive; var n, i, num, sum: integer; begin // Вводим количество чисел в последовательности readln(n); // Инициализируем переменную для хранения суммы sum := 0; // Читаем числа и суммируем кратные 5 for i := 1 to n do begin readln(num); if (num mod 5 = 0) then sum := sum + num; end; // Выводим результат writeln(sum); end.
Программа на языке Pascal для нахождения минимального числа, оканчивающегося на 4, в последовательности:
pascalprogram MinNumberEndingWithFour; var n, i, num, minNum: integer; begin // Вводим количество чисел в последовательности readln(n); // Инициализируем переменную для хранения минимального числа, оканчивающегося на 4 minNum := 40000; // Максимальное возможное значение, чтобы гарантировать нахождение числа в последовательности // Читаем числа и находим минимальное число, оканчивающееся на 4 for i := 1 to n do begin readln(num); if (num mod 10 = 4) and (num < minNum) then minNum := num; end; // Выводим результат writeln(minNum); end.
Обе программы считывают входные данные с консоли и выводят результат на экран. Вы можете вводить числа последовательности по одному и нажимать Enter после каждого числа. После ввода всех чисел программа выведет результат. Обратите внимание, что обе программы предполагают, что в последовательности есть хотя бы одно число, удовлетворяющее условиям задачи.
Похожие вопросы
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
