Вопрос задан 24.10.2023 в 11:38. Предмет Информатика. Спрашивает Бурков Кирилл.

Напишите программу для нахождения минимальной и максимальной цифры в числе.Язык c++

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Артамонов Максим.

Ответ:

#include <iostream>

#define max 100

using namespace std;

int index;

char input = 0;

int ln;

char min = '9' + 1;

char max = '0';

int nul;

int main()

{

   cin >> input;

   

   for(int j = 0; input[j] != '\0'; j++){

       ln = j + 1;

   }

   

   for(int j = 0; j < ln ; j++){

       if( input[j] < min){

           min = input[j];

       }

   }

   

   for(int j = 0; j < ln ; j++){

       if (input[j] > max){

           max = input[j];

       }

   }

   cout << "max:" <<  max;

   cout << "min:" << min;

   cin >> nul;

   

   return 0;

}

P.S.я не уверен, если у тебя не запуститься пиши

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на C++ для нахождения минимальной и максимальной цифры в числе:

```cpp #include using namespace std;

int main() { int number; cout << "Введите число: "; cin >> number;

int minDigit = 9; // инициализируем минимальную цифру максимально возможным значением int maxDigit = 0; // инициализируем максимальную цифру минимально возможным значением

while (number > 0) { int digit = number % 10; // получаем последнюю цифру числа

if (digit < minDigit) { minDigit = digit; // обновляем минимальную цифру, если найдена меньшая }

if (digit > maxDigit) { maxDigit = digit; // обновляем максимальную цифру, если найдена большая }

number /= 10; // сокращаем число на одну цифру справа }

cout << "Минимальная цифра: " << minDigit << endl; cout << "Максимальная цифра: " << maxDigit << endl;

return 0; } ```

В этой программе мы считываем число от пользователя и затем с помощью цикла while проходим по всем его цифрам.

В каждой итерации цикла мы получаем последнюю цифру числа с помощью операции остатка от деления на 10 (`number % 10`) и сохраняем её в переменную `digit`.

Затем мы сравниваем `digit` с текущими значениями `minDigit` и `maxDigit`. Если `digit` меньше `minDigit`, то обновляем значение `minDigit`. Если `digit` больше `maxDigit`, то обновляем значение `maxDigit`.

После окончания цикла выводим найденные минимальную и максимальную цифры на экран.

Например, если пользователь введет число 548763, программа выведет:

``` Минимальная цифра: 3 Максимальная цифра: 8 ```

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос