Вопрос задан 09.07.2023 в 12:00. Предмет Информатика. Спрашивает Артамонова Дина.

Написать программу в паскале. Сравнить два числа, если число больше 10 то умножить его на 2, если

меньше то прибавить к нему 20. ПОЖАЛУЙСТА
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Куртсеитов Эскендер.

program srav;

var

x : integer;

 begin

if x > 10 then

 x := x *2;

if x < 10 then

 x:= x +20;

 end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Pascal, который сравнивает два числа и выполняет требуемые операции:

pascal
program CompareNumbers; var number1, number2: Integer; begin writeln('Введите первое число:'); readln(number1); writeln('Введите второе число:'); readln(number2); if number1 > 10 then number1 := number1 * 2 else number1 := number1 + 20; if number2 > 10 then number2 := number2 * 2 else number2 := number2 + 20; writeln('Результаты:'); writeln('Первое число:', number1); writeln('Второе число:', number2); end.

Программа запрашивает у пользователя два числа и затем сравнивает их с 10. Если число больше 10, то оно умножается на 2, иначе к нему прибавляется 20. Результаты операций выводятся на экран.

Обратите внимание, что данная программа предполагает, что пользователь будет вводить целые числа. Если вам нужно работать с числами с плавающей точкой, вам следует использовать тип Real вместо Integer.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос