Вопрос задан 24.10.2023 в 06:32. Предмет Информатика. Спрашивает Тлебалдиева Гульназ.

Напишите программу калькулятор

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пинчук Ирина.

Ответ:

Простейший калькулятор Pascal c основным функционалом:

Объяснение:

Program HelloWorld(output);

var

a,b,c : real;

begin

   Write('a = ');

   Readln(a);

   Write('b = ');

   Readln(b);

   c := a+b;

   Writeln('a + b = ',c);

   c := a-b;

   Writeln('a - b = ',c);

   c := a*b;

   Writeln('a * b = ',c);

   c := a/b;

   Writeln('a / b = ',c);

   Writeln('---------------');

   c := Sqr(36 + 24)/Sqrt(8-5);

   Writeln(c);

end.

0 0
Отвечает Сусский Антон.

Ответ:

Это Python

PS: пиши язык

Объяснение:

a=int(input())

b=str(input())

c=int(input())

if b=="+":

   print (a+c)

elif b=="-":

   print (a-c)

elif b=="*":

   print (a*c)

elif b=="/":

   print (a/c)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот простой калькулятор на Python. Он может выполнять базовые математические операции: сложение, вычитание, умножение и деление. Вы можете ввести числа и оператор, а затем программа вернет результат.

python
# Функция для сложения def add(x, y): return x + y # Функция для вычитания def subtract(x, y): return x - y # Функция для умножения def multiply(x, y): return x * y # Функция для деления def divide(x, y): if y == 0: return "Деление на ноль невозможно" return x / y # Основная функция калькулятора def calculator(): print("Выберите операцию:") print("1. Сложение") print("2. Вычитание") print("3. Умножение") print("4. Деление") choice = input("Введите номер операции (1/2/3/4): ") if choice not in ('1', '2', '3', '4'): print("Неправильный выбор") return num1 = float(input("Введите первое число: ")) num2 = float(input("Введите второе число: ")) if choice == '1': print("Результат:", add(num1, num2)) elif choice == '2': print("Результат:", subtract(num1, num2)) elif choice == '3': print("Результат:", multiply(num1, num2)) elif choice == '4': result = divide(num1, num2) if type(result) == str: print(result) else: print("Результат:", result) if __name__ == "__main__": calculator()

Просто скопируйте этот код и выполните его в среде Python. Программа предложит вам выбрать операцию и ввести числа для выполнения выбранной операции.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос