Написать программу в паскале, тема массивы Возвести в квадрат элементы, не превосходящие по
модулю введенное с клавиатуры число R.Ответы на вопрос
const n=10;
var a:array[1..n] of integer;
i,r: integer;
begin
write (' Исходный массив: ');
for i:=1 to n do
begin
a[i]:=random(41)-20;
write (a[i]:3,' ')
end;
writeln;
write ('Введите число: ');
readln (r);
write ('Преобразованый массив: ');
for i:=1 to n do
begin
if abs(a[i]) <= r then a[i]:=a[i]*a[i];
write (a[i]:3,' ')
end
end.
Для решения данной задачи на языке Паскаль можно написать следующую программу:
```pascal program SquaringArrayElements;
const N = 5; // размер массива
var A: array[1..N] of Integer; // объявление массива R, i: Integer; // переменные для ввода числа R и цикла
begin // Ввод числа R с клавиатуры Write('Введите число R: '); Readln(R);
// Ввод элементов массива с клавиатуры Writeln('Введите элементы массива:'); for i := 1 to N do begin Write('A[', i, '] = '); Readln(A[i]); end;
// Возведение в квадрат элементов, не превосходящих по модулю число R for i := 1 to N do begin if Abs(A[i]) <= R then A[i] := A[i] * A[i]; end;
// Вывод элементов массива после возведения в квадрат Writeln('Массив после возведения в квадрат элементов, не превосходящих по модулю число R:'); for i := 1 to N do Write(A[i], ' ');
Readln; end. ```
В данной программе мы объявляем массив `A` размером `N` и переменные `R` и `i`. Затем мы считываем число `R` с клавиатуры и вводим элементы массива `A`. Далее мы проходим по каждому элементу массива и, если его значение по модулю не превосходит число `R`, возводим его в квадрат. Наконец, выводим элементы массива после возведения в квадрат.
Примечание: В данной программе предполагается, что размер массива `N` равен 5. Вы можете изменить значение `N` в соответствии с вашими потребностями.
Источники: - - Turbo Pascal - - PASCAL - - artemiosdev/Algorithms-and-Data-Structures-in-Python ... - GitHub - - Turbo Pascal Delphi - - ( -7.0)
Для написания программы на языке Pascal, которая возводит в квадрат элементы массива, не превосходящие по модулю введенное с клавиатуры число R, вам потребуется выполнить следующие шаги:
1. Объявить переменные. 2. Запросить у пользователя размер массива и число R. 3. Создать массив и заполнить его случайными числами. 4. Пройти по массиву и возвести в квадрат только те элементы, которые не превосходят по модулю число R. 5. Вывести исходный и измененный массив на экран.
Вот пример программы на Pascal, выполняющей описанные шаги:
```pascal program SquareArrayElements;
const MaxArraySize = 100;
var arr: array[1..MaxArraySize] of Integer; n, R, i: Integer;
begin // Шаг 2: Ввод размера массива и числа R Write('Введите размер массива: '); Readln(n);
if (n < 1) or (n > MaxArraySize) then begin Writeln('Неверный размер массива. Допустимый диапазон: 1..', MaxArraySize); Halt; end;
Write('Введите число R: '); Readln(R);
// Шаг 3: Заполнение массива случайными числами Randomize; // Инициализация генератора случайных чисел for i := 1 to n do begin arr[i] := Random(201) - 100; // Генерируем случайное число в диапазоне [-100, 100] end;
// Шаг 4: Возвести в квадрат элементы, не превосходящие по модулю число R for i := 1 to n do begin if abs(arr[i]) <= R then arr[i] := arr[i] * arr[i]; end;
// Шаг 5: Вывод массива до и после изменений Writeln('Исходный массив:'); for i := 1 to n do Write(arr[i], ' '); Writeln;
Writeln('Массив после возведения в квадрат:'); for i := 1 to n do Write(arr[i], ' '); Writeln;
Readln; end. ```
Эта программа сначала запрашивает у пользователя размер массива и число R, затем заполняет массив случайными числами в диапазоне от -100 до 100 и возводит в квадрат только те элементы, которые не превосходят по модулю число R. Результаты выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
