Вопрос задан 12.10.2023 в 15:41. Предмет Информатика. Спрашивает Райская Леся.

Задание в паскале нужно написать программу: Дан двумерный массив случайных чисел от -05 до 14 из

5 строк и 5 столбцов.Вывести на экран первоначальные значения элементов массива в виде матрицы. Поменять местами первый и второй столбец.Вывести на экран новые значения элементов массива в виде матрицы Кто знает,помогите, с меня презент)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Саросек Юля.
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(5,5,-5,14);
  a.Println(4); Writeln(4*a.ColCount*'-');
  a.SwapCols(0,1);
  Writeln('*** Результирующий массив ***');
  a.Println(4);
end.

Пример
*** Исходный массив ***
  12  10   7  -2   5
  14   0   7   1  14
   0  -1   7   5   7
  -5  -5  -4  -4   9
   7   8  -5  12  12
--------------------
*** Результирующий массив ***
  10  12   7  -2   5
   0  14   7   1  14
  -1   0   7   5   7
  -5  -5  -4  -4   9
   8   7  -5  12  12
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам с этим заданием. Вот программа на Pascal, которая выполняет описанные вами шаги:

pascal
program SwapColumns; const ROWS = 5; COLS = 5; type Matrix = array[1..ROWS, 1..COLS] of integer; var arr: Matrix; i, j, temp: integer; procedure PrintMatrix(var A: Matrix); var i, j: integer; begin for i := 1 to ROWS do begin for j := 1 to COLS do write(A[i, j]:4); writeln; end; end; begin // Заполняем массив случайными числами от -5 до 14 randomize; for i := 1 to ROWS do for j := 1 to COLS do arr[i, j] := random(20) - 5; // Выводим начальную матрицу writeln('Начальная матрица:'); PrintMatrix(arr); writeln; // Меняем местами первый и второй столбцы for i := 1 to ROWS do begin temp := arr[i, 1]; arr[i, 1] := arr[i, 2]; arr[i, 2] := temp; end; // Выводим измененную матрицу writeln('Матрица после замены столбцов:'); PrintMatrix(arr); end.

Эта программа создает двумерный массив размером 5x5, заполняет его случайными числами от -5 до 14, затем меняет местами первый и второй столбцы и выводит начальную и измененную матрицы. Не забудьте скомпилировать и запустить программу в среде разработки Pascal. Надеюсь, это поможет вам с вашим заданием!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос