СРОЧНО!!! Помогите написать программу языком С++ ДАЮ 100 БАЛОВ!! Задано целочисленный массив
(матрица) А размерности 5х5. Массив А инициализировать элементами в тексте программы при его описании (заполнить произвольно - 5 строк по 5 чисел). В массиве А найти указанные в варианте задачи величины и вывести результат в виде сообщения на консоль, выведя предварительно массив в виде таблицы. Образовать новый массив В, согласно указаниям соответствующего варианта, образованный массив вывести на консоль. ЗАДАЧА: В массиве А найти разницу средних значений отдельно взятых положительных и отрицательное элементов. Массив В образовать из массива А, заменив в нем все элементы меньше -5 на противоположные. ЗА ПРАВИЛЬНУЮ ПОМОЩЬ ОТДАМ ВСЕ БАЛЫ И ВЫБЕРУ ЛУЧШИЙ ОТВЕТ! ЗАРАНЕЕ СПАСИБО!)Ответы на вопрос
Ответ:
#include <iostream>
#include <iomanip>
using namespace std;
int main()
{
int a[5][5] =
{
{4,-5,8,-3,1},
{-3,8,-1,1,-8},
{9,6,6,-3,-7},
{-7,-3,3,6,-7},
{7,-3,-6,5,0},
};
int b[5][5];
int i, j, cp, cm, sp, sm;
setlocale(LC_ALL, "Russian");
cout << "Массив A";
for (i = 0; i < 5; i++) {
cout << endl;
for (j = 0; j < 5; j++) {
cout << setw (4) << a[i][j];
}
}
cp = cm = sp = sm = 0;
for (i = 0; i < 5; i++) {
for (j = 0; j < 5; j++) {
if (a[i][j] >= -5)
b[i][j] = a[i][j];
else
b[i][j] = - a[i][j];
if (a[i][j] > 0) {
cp++;
sp += a[i][j];
}
if (a[i][j] < 0) {
cm++;
sm += a[i][j];
}
}
}
cout << endl << endl;
cout << "Среднее значение положительных элементов = " << (float) sp / cp << endl;
cout << "Среднее значение отрицательных элементов = " << (float) sm / cm << endl << endl;
cout << "Массив B";
for (i = 0; i < 5; i++) {
cout << endl;
for (j = 0; j < 5; j++) {
cout << setw(4) << b[i][j];
}
}
return 0;
}
Конечно, я могу помочь вам написать программу на C++, которая решает вашу задачу. Вот пример кода:
cpp#include <iostream>
int main() {
// Инициализация массива А
int A[5][5] = {
{1, -2, 3, -4, 5},
{-6, 7, -8, 9, -10},
{11, -12, 13, -14, 15},
{-16, 17, -18, 19, -20},
{21, -22, 23, -24, 25}
};
// Вывод массива А в виде таблицы
std::cout << "Массив А:" << std::endl;
for (int i = 0; i < 5; i++) {
for (int j = 0; j < 5; j++) {
std::cout << A[i][j] << "\t";
}
std::cout << std::endl;
}
// Находим средние значения положительных и отрицательных элементов
double sumPositive = 0;
double sumNegative = 0;
int countPositive = 0;
int countNegative = 0;
for (int i = 0; i < 5; i++) {
for (int j = 0; j < 5; j++) {
if (A[i][j] > 0) {
sumPositive += A[i][j];
countPositive++;
} else if (A[i][j] < 0) {
sumNegative += A[i][j];
countNegative++;
}
}
}
double averagePositive = sumPositive / countPositive;
double averageNegative = sumNegative / countNegative;
// Вычисляем разницу между средними значениями
double diff = averagePositive - averageNegative;
std::cout << "Разница между средними значениями положительных и отрицательных элементов: " << diff << std::endl;
// Создаем массив В и заменяем элементы меньше -5 на противоположные
int B[5][5];
for (int i = 0; i < 5; i++) {
for (int j = 0; j < 5; j++) {
if (A[i][j] < -5) {
B[i][j] = -A[i][j];
} else {
B[i][j] = A[i][j];
}
}
}
// Вывод массива В
std::cout << "Массив В:" << std::endl;
for (int i = 0; i < 5; i++) {
for (int j = 0; j < 5; j++) {
std::cout << B[i][j] << "\t";
}
std::cout << std::endl;
}
return 0;
}
Этот код создает массив А размерности 5x5, находит средние значения положительных и отрицательных элементов в нем, вычисляет разницу между этими средними значениями и создает массив B, заменяя элементы меньше -5 на их противоположные значения. После чего он выводит оба массива на консоль.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
