Вопрос задан 05.10.2023 в 02:15. Предмет Информатика. Спрашивает Бердников Миша.

Напишите программу, в которой даны три действительных числа. Возвести в квадрат положительные числа

и в четвертую степень - отрицательные c#
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ярмуш Тёма.

Ответ:

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           double a, b, c;

           Console.WriteLine("Введите a:");

           a = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите b:");

           b = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите c:");

           c = Convert.ToDouble(Console.ReadLine());

           Console.Write("Результат: {0} , {1}, {2}", (a > 0) ? a * a : a * a * a * a,

               (b > 0) ? b * b : b * b * b * b, (c > 0) ? c * c : c * c * c * c);

       }

   }

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на C#, которая выполняет указанные действия:

csharp
using System; class Program { static void Main() { Console.WriteLine("Введите три действительных числа:"); // Ввод трех чисел с клавиатуры double num1 = Convert.ToDouble(Console.ReadLine()); double num2 = Convert.ToDouble(Console.ReadLine()); double num3 = Convert.ToDouble(Console.ReadLine()); // Возводим в квадрат положительные числа double result1 = (num1 > 0) ? Math.Pow(num1, 2) : num1; double result2 = (num2 > 0) ? Math.Pow(num2, 2) : Math.Pow(num2, 4); double result3 = (num3 > 0) ? Math.Pow(num3, 2) : Math.Pow(num3, 4); // Вывод результатов Console.WriteLine($"Результат для первого числа: {result1}"); Console.WriteLine($"Результат для второго числа: {result2}"); Console.WriteLine($"Результат для третьего числа: {result3}"); } }

Программа запрашивает у пользователя ввод трех действительных чисел, затем возводит положительные числа в квадрат, а отрицательные в четвертую степень. Результаты выводятся на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос