 
Вопрос задан 03.10.2023 в 00:06.
Предмет Информатика.
Спрашивает Дубровина Ира.
1Напишите программу, которая получает на вход номер месяца (целым числом), а на выходе показывает
время года. *Cрочно 2Напишите программу для решения выражения: x+2*y-14. На вход подаются значения x и y (целые числа), на выходе программа выдаёт получившееся в результате решения число. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Ермолин Данил.
                
    Ответ:
1. program vremya_goda;
var i:integer;
begin
writeln('Введите номер месяца ');
readln(i);
if (i>=1) and (i<=12) then
Begin
Write('');
case i of
12,1,2:write('Зима');
3,4,5:write('Весна');
6,7,8:write('Лето');
9,10,11:write('Осень');
end;
end;
end.
2. program raschet;
var f,x,y:integer;
begin
writeln('Введите два числа');
readln(x,y);
f:=x+2*y-14;
writeln('Ваше значение: ', f );
end.
Объяснение:
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Давайте начнем с написания программы на Python для определения времени года в зависимости от номера месяца:
python# Получаем номер месяца от пользователя
month = int(input("Введите номер месяца (1-12): "))
# Проверяем, в какое время года попадает месяц
if month in [12, 1, 2]:
    season = "Зима"
elif month in [3, 4, 5]:
    season = "Весна"
elif month in [6, 7, 8]:
    season = "Лето"
elif month in [9, 10, 11]:
    season = "Осень"
else:
    season = "Неверный номер месяца"
# Выводим результат
print(f"Время года: {season}")
Теперь давайте напишем программу для решения выражения x + 2*y - 14, где x и y - целые числа:
python# Получаем значения x и y от пользователя
x = int(input("Введите значение x: "))
y = int(input("Введите значение y: "))
# Решаем выражение
result = x + 2 * y - 14
# Выводим результат
print(f"Результат выражения x + 2*y - 14: {result}")
Скопируйте каждую из этих программ в файлы с расширением .py, чтобы выполнить их в вашей среде выполнения Python.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			