Вопрос задан 30.09.2023 в 22:53.
Предмет Информатика.
Спрашивает Лабытнанский Денис.
Паскаль. Написать программу для нахождения площади прямоугольника. формулы y1=(x+y)/3-t
Ответы на вопрос
Отвечает Волкова Елизавета.
Ответ:
Program lol;
Var a, b, c, s, p:real;
begin
write('Введите длины трех сторон треугольника: ');
readln(a,b,c);
p := (a + b + c) / 2;
s := sqrt(p * (p-a) * (p-b) * (p-c));
writeln('Площадь тр-ка S = ', s);
end.
Объяснение:

Отвечает Весновская Маргарита.
Program Pr_yg;
Uses crt;
Var
S,a,b:real;
Begin
writeln('Введите стороны прямоугольника');
readln(a,b);
S:=a*b;
writeln('Площадь прямоугольника равна',S);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для нахождения площади прямоугольника с помощью формулы y1=(x+y)/3-t в языке программирования Pascal, вы можете использовать следующий код:
pascalprogram CalculateRectangleArea; var x, y, t: real; y1, area: real; begin writeln('Введите значение x: '); readln(x); writeln('Введите значение y: '); readln(y); writeln('Введите значение t: '); readln(t); y1 := (x + y) / 3 - t; area := x * y1; writeln('Площадь прямоугольника равна: ', area:0:2); end.
Эта программа сначала запрашивает значения x, y и t от пользователя, затем вычисляет y1 по заданной формуле и, наконец, находит площадь прямоугольника, умножая x на y1. Результат выводится на экран.
Похожие вопросы
Информатика 78
Информатика 94
Информатика 28
Информатика 19
Информатика 88
Информатика 64
Информатика 22
Информатика 70
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
