Вопрос задан 22.07.2018 в 23:33. Предмет Информатика. Спрашивает Барабанова Дарья.

Составить программу расчёта площади и периметра треугольника Помогите пожалуйста

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бахвалов Дима.

Вот на Pascal:

uses graphabc;
var a,b,c:longint;
begin
write('Введите a,b и c треугольника');
readln(a,b,c);
write('Периметр - ',a+b+c);
write('Площадь - ',a*b*c);
write('Code by Grisha Sheldunov');
end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для расчета площади и периметра треугольника

Для расчета площади и периметра треугольника, можно использовать следующую программу на языке C++:

```cpp #include #include

using namespace std;

// Функция для расчета площади треугольника double calculateArea(double a, double b, double c) { double s = (a + b + c) / 2; // Полупериметр треугольника double area = sqrt(s * (s - a) * (s - b) * (s - c)); // Формула Герона для расчета площади return area; }

// Функция для расчета периметра треугольника double calculatePerimeter(double a, double b, double c) { double perimeter = a + b + c; return perimeter; }

int main() { double side1, side2, side3; // Ввод длин сторон треугольника cout << "Введите длину первой стороны треугольника: "; cin >> side1; cout << "Введите длину второй стороны треугольника: "; cin >> side2; cout << "Введите длину третьей стороны треугольника: "; cin >> side3; // Расчет и вывод площади треугольника double area = calculateArea(side1, side2, side3); cout << "Площадь треугольника: " << area << endl; // Расчет и вывод периметра треугольника double perimeter = calculatePerimeter(side1, side2, side3); cout << "Периметр треугольника: " << perimeter << endl; return 0; } ```

Программа позволяет пользователю ввести длины трех сторон треугольника и вычисляет его площадь и периметр, используя формулу Герона для площади треугольника.

Примечание: Данная программа предполагает, что введенные значения являются корректными сторонами треугольника. Если введенные значения не могут образовать треугольник, то результаты могут быть некорректными.

Надеюсь, эта информация будет полезной! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос