
Напишите программу на C ++, чтобы найти площадь и периметр прямоугольника. (процедура/функция )


Ответы на вопрос

Ответ:
#include <iostream>
#include <locale>
using namespace std;
const int NotUsed = system("color 7D"); //изменение цвета консоли. Не пиши!
void Square(double a, double b)
{
double S = 1;
S = a * b;
cout << "Площадь: " << S << endl;
}
void Perimeter(double a, double b) {
double P = 1;
P = 2 * (a + b);
cout << "Периметр: " << P << endl;
}
int main() {
setlocale(LC_ALL, "Russian");
double P, S;
double a, b;
cout << "Введите стороны прямоугольника: ";
cin >> a >> b;
Square(a, b);
Perimeter(a, b);
system("PAUSE");
return 0;
}
Объяснение:
Использовал функции, как и сказано.



Конечно, вот программа на C++, которая вычисляет площадь и периметр прямоугольника с использованием функций:
cpp#include <iostream>
// Функция для вычисления площади прямоугольника
double calculateArea(double length, double width) {
return length * width;
}
// Функция для вычисления периметра прямоугольника
double calculatePerimeter(double length, double width) {
return 2 * (length + width);
}
int main() {
double length, width;
std::cout << "Введите длину прямоугольника: ";
std::cin >> length;
std::cout << "Введите ширину прямоугольника: ";
std::cin >> width;
double area = calculateArea(length, width);
double perimeter = calculatePerimeter(length, width);
std::cout << "Площадь прямоугольника: " << area << std::endl;
std::cout << "Периметр прямоугольника: " << perimeter << std::endl;
return 0;
}
Эта программа сначала запрашивает у пользователя длину и ширину прямоугольника, затем вызывает функции calculateArea
и calculatePerimeter
для вычисления площади и периметра, и, наконец, выводит результаты на экран.


Похожие вопросы









Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili