Вопрос задан 02.04.2018 в 08:02.
Предмет Информатика.
Спрашивает Fedorova Lana.
составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит
на экран дисплея площадь квадрата.процедура P1 вводит с клавиатуры длину стороны квадрата;функция F1 вычисляет площадь квадрата;Процедура P2 выводит на экран результат.процедура P1 и функции F1 - встроенный в программупроцедура P2 - записывается как отдельный модуль подключаемый к основной программе.в паскалеОтветы на вопрос
Отвечает Шестакова Ксения.
программа на Turbo pascal 7.1:
содержание progs.pas:
{$N+}{-директива для подключения 8087 препоцессора}
uses output1; {здесь подключаем модуль output1}
var p:double;
function F1(p:double):double;
begin
F1:=Sqr(p);
end;
procedure P1(var p:double);
begin
readln(p);
p:=F1(p);
end;
begin
write('Введите длину стороны квадрата = ');
P1(p);
P2(p);
end.
содержание output1.tpu:
{$N+}{-директива для подключения 8087 препоцессора}
unit output1;{здесь объявляем модуль output1}
interface
procedure P2(p:double);
implementation
procedure P2;
begin
writeln('Площадь квадрата = ',p:0:5);
end;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
