Вопрос задан 06.09.2023 в 03:32.
Предмет Информатика.
Спрашивает Сухотенко Валерия.
Помогите с задачей на паскале.. Даны 100 целых чисел, принадлежащих интервалу [0; 1000].
Определите количество тех из них, которые делятся на 7.Числа следующие: 127; 60; 255; 579; 525; 545; 425; 984; 320; 159; 193; 408; 742; 732; 767; 924; 504; 399; 720; 321; 571; 254; 53; 878; 392; 228; 548; 237; 196; 90; 469; 824; 639; 36; 391; 546; 272; 630; 256; 681; 487; 331; 904; 755; 41; 380; 540; 839; 61; 973; 269; 783; 629; 201; 33; 805; 605; 468; 672; 549; 277; 601; 921; 498; 772; 737; 354; 502; 641; 439; 915; 838; 746; 698; 441; 90; 904; 223; 670; 743; 240; 270; 646; 704; 779; 873; 370; 721; 910; 962; 152; 850; 450; 306; 729; 632; 467; 632; 144; 918Ответы на вопрос
Отвечает Губарева Катюшка.
Var
a:array[1..1000]of integer;
i,n,m,k:integer;
begin
m:=0;
k:=0;
Writeln('введите числа:');
For i:=1 to 100 do
Readln (a[i]);
for i:=1 to 100 do
begin
if(a[i]mod 7=0) then
k:=k+1;
end;
writeln (k);
end.
Вот держи выводит количество цифр
a:array[1..1000]of integer;
i,n,m,k:integer;
begin
m:=0;
k:=0;
Writeln('введите числа:');
For i:=1 to 100 do
Readln (a[i]);
for i:=1 to 100 do
begin
if(a[i]mod 7=0) then
k:=k+1;
end;
writeln (k);
end.
Вот держи выводит количество цифр
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на Паскале, вы можете создать программу, которая будет проходить через каждое из 100 целых чисел и проверять, делится ли оно на 7 без остатка. Если число делится на 7, увеличивайте счетчик. Вот как это может быть реализовано на Паскале:
pascalprogram CountDivisibleBy7; var numbers: array[1..100] of integer; count, i: integer; begin count := 0; { Введите все 100 целых чисел в массив numbers } numbers[1] := 127; numbers[2] := 60; numbers[3] := 255; { Добавьте остальные числа здесь } for i := 1 to 100 do begin if numbers[i] mod 7 = 0 then count := count + 1; end; writeln('Количество чисел, которые делятся на 7: ', count); end.
В этой программе мы создали массив numbers, в котором хранятся все 100 целых чисел. Затем мы проходим через каждый элемент массива и используем оператор mod для проверки, делится ли число на 7 без остатка. Если да, то увеличиваем счетчик count. По завершении цикла, программа выводит количество чисел, которые делятся на 7.
Похожие вопросы
Информатика 11
Информатика 18
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
