Вопрос задан 02.08.2023 в 06:29.
Предмет Информатика.
Спрашивает Тихий Ярослав.
Составить программу. Вывести на экран квадраты нечетных чисел от 1 до 20. На Pascale'е.
Ответы на вопрос
Отвечает Мемех София.
Var i:integer;
begin
for i:=1 to 20 do
if not(odd(i) then Writeln(sqr(i));
end.
begin
for i:=1 to 20 do
if not(odd(i) then Writeln(sqr(i));
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Pascal, которая выводит квадраты нечетных чисел от 1 до 20:
pascalprogram PrintOddSquares; var i, square: integer; begin writeln('Квадраты нечетных чисел от 1 до 20:'); for i := 1 to 20 do begin // Проверяем, является ли число нечетным if i mod 2 <> 0 then begin square := i * i; // Вычисляем квадрат числа writeln(i, '^2 = ', square); end; end; end.
Эта программа использует цикл for для перебора чисел от 1 до 20 и проверяет, является ли каждое число нечетным с помощью оператора mod. Если число нечетное, то оно возводится в квадрат и выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 10
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
