Напишите программу в паскаль. ДАМ 20 БАЛЛОВ!!! Вывести на экран все нечетные числа меньше
введенного x. Вывести на экран все числа кратные 5 меньше введенного x. Вывести на экран n четных чисел так, чтобы числа выводились в обратном порядке – от большего к 2. Вывести на экран n нечетных чисел так, чтобы числа выводились в обратном порядке – от большего к 1. Вывести на экран все цифры числа, введенного с клавиатуры. Определить, сколько цифр в числе, введенном с клавиатуры.Ответы на вопрос
Ответ:
begin
//PascalABC.NET 3.8.2
var num := ReadInteger;
SeqWhile(1, x -> x + 2, x -> x < num).Println;
num := ReadInteger;
SeqWhile(5, x -> x + 5, x -> x < num).Println;
SeqGen(ReadInteger, 2, x -> x + 2).Reverse.Println;
SeqGen(ReadInteger, 1, x -> x + 2).Reverse.Println;
ReadInteger.ToString.ForEach(x -> Write(x, ' '));
Writeln;
ReadInteger.ToString.Length.Println;
end.
Конечно, ниже представлена программа на языке Pascal, которая выполняет все указанные действия:
```pascal program Numbers;
var x, n, count, number, digit: integer; i: integer;
begin // Ввод числа x Write('Введите число x: '); ReadLn(x); // Вывод всех нечетных чисел меньше x WriteLn('Все нечетные числа меньше ', x, ': '); for i := 1 to x - 1 do begin if (i mod 2) <> 0 then WriteLn(i); end;
// Вывод всех чисел кратных 5 меньше x WriteLn('Все числа, кратные 5 и меньше ', x, ': '); for i := 1 to x - 1 do begin if (i mod 5) = 0 then WriteLn(i); end;
// Вывод n четных чисел в обратном порядке Write('Введите n: '); ReadLn(n); WriteLn('Первые ', n, ' четных чисел в обратном порядке: '); count := 0; for i := x downto 2 do begin if (i mod 2) = 0 then begin WriteLn(i); count := count + 1; if count = n then Break; end; end;
// Вывод n нечетных чисел в обратном порядке WriteLn('Первые ', n, ' нечетных чисел в обратном порядке: '); count := 0; for i := x - 1 downto 1 do begin if (i mod 2) <> 0 then begin WriteLn(i); count := count + 1; if count = n then Break; end; end;
// Вывод всех цифр числа, введенного с клавиатуры Write('Введите число: '); ReadLn(number); WriteLn('Все цифры числа ', number, ': '); while number > 0 do begin digit := number mod 10; WriteLn(digit); number := number div 10; end;
// Определение количества цифр числа, введенного с клавиатуры count := 0; number := number; repeat count := count + 1; number := number div 10; until number = 0;
WriteLn('Количество цифр в числе: ', count); ReadLn; end. ```
Обратите внимание, что в программе используется операторы ввода и вывода (WriteLn, ReadLn), которые позволяют взаимодействовать с пользователем. Также используются операторы цикла (for, while, repeat) и условные операторы (if, break), чтобы выполнить необходимые действия.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
