Написать программу в который будет спрашиваться кол-во чисел в массиве. Числа будут вводится в
ручную, а потом среди них выведется которое делится на 9 без остатка. С#Ответы на вопрос
Лови:
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApp3
{
class Program
{
static void Main(string[] args)
{
Console.WriteLine("Введте длину массива:");
int a = Convert.ToInt16(Console.ReadLine());
int[] array = new int[a];
Console.WriteLine("Введите массив:");
for(int i = 0; i < a; i++)
{
array[i] = Convert.ToInt16(Console.ReadLine());
}
Console.WriteLine("Числа делящиеся на 9 без остатка:");
for(int i = 0; i < a; i++)
{
if(array[i]%9 == 0)
{
Console.WriteLine(array[i]+" ");
}
}
}
}
}
Для решения этой задачи вам нужно написать программу на языке C#, которая запросит у пользователя количество чисел в массиве, затем попросит пользователя ввести каждое число, и, наконец, выведет число (или числа), которое делится на 9 без остатка.
Вот пример кода программы:
csharpusing System;
namespace DivisibleByNine
{
class Program
{
static void Main(string[] args)
{
Console.WriteLine("Введите количество чисел в массиве:");
int count = int.Parse(Console.ReadLine());
int[] numbers = new int[count];
for (int i = 0; i < count; i++)
{
Console.Write($"Введите число {i + 1}: ");
numbers[i] = int.Parse(Console.ReadLine());
}
Console.WriteLine("Числа, которые делятся на 9 без остатка:");
bool found = false;
foreach (int num in numbers)
{
if (num % 9 == 0)
{
Console.WriteLine(num);
found = true;
}
}
if (!found)
{
Console.WriteLine("В массиве нет чисел, которые делятся на 9 без остатка.");
}
}
}
}
Как работает код:
- Пользователь вводит количество чисел в массиве.
- Затем пользователь последовательно вводит каждое число.
- Программа проходится по массиву и проверяет каждое число на делимость на 9.
- Если находится число, которое делится на 9 без остатка, оно выводится на экран.
- Если таких чисел нет, выводится сообщение об отсутствии таких чисел.
Примечание: В этом примере предполагается, что пользователь будет вводить корректные целочисленные значения. В реальной программе стоит предусмотреть обработку ошибок, чтобы избежать сбоев при вводе некорректных данных.
Похожие вопросы
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
