Нужно написать программу ПАскаль или С++. Робот фиксирует количество людей, пользующихся автобусом
маршрута №22, идущего мимо площади, на которой идет празднование Наурыз. Он фиксирует количество выходящих и входящих людей на остановке. Помогите Роботу подвести итог работы за день. Формат входных данных Число N – количество автобусов (N <= 100), N пар чисел – число входящих и выходящих человек (от 0 до 50). Формат результата Два числа - количество людей, приехавших на площадь и количество людей, покинувших площадь на автобусе маршрута №22. Входные данные 4 Результат работы 31 27 Входные данные 9 5 4 7 6 6 12 9Ответы на вопрос
        
2
3
4
5
6
7
8
9
10
11
12
Program L5Z1;
var K:array[0..17] of real; i:real; c:integer;
begin
writeln('Зформовані масиви: ');
i:=1;
for c:=0 to 17 do
begin
K[c]:=(((-1)*c)+3*c)/(c+1);
writeln('K[',i,']=',K[c]:2:3);
i:=i+1;
end;
end.
            Для решения этой задачи можно написать программу на языке C++. Вот пример решения:
cpp#include <iostream>
using namespace std;
int main() {
    int N;
    cin >> N;
    int totalArriving = 0;
    int totalDeparting = 0;
    for (int i = 0; i < N; i++) {
        int incoming, outgoing;
        cin >> incoming >> outgoing;
        
        totalArriving += incoming;
        totalDeparting += outgoing;
    }
    cout << totalArriving << " " << totalDeparting << endl;
    return 0;
}
Суть программы заключается в считывании количества автобусов (N) и затем для каждого автобуса считываются два числа - число входящих и число выходящих пассажиров. Затем эти числа суммируются в соответствующих переменных (totalArriving и totalDeparting). В конце программы выводится итоговое количество прибывших и убывших пассажиров на площади.
Пример входных данных:
4 9 5 4 7 6 6 12 9
Результат работы:
31 27
Другими словами, 31 человек приехали на площадь, а 27 человек покинули площадь на автобусе маршрута №22.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			