Помогите написать в паскале Задача Найти минимальное из чётных элементов массива пяти целых
чисел.Задача По фигурному катанию N судей выставляют оценки. Наибольшая и наименьшая отбрасываются, а по остальным выставляется средний бал. Напишите программу, вычисляющую среднюю оценку и выдайте номер судей, которые поставилинаибольшую и наименьшую оценки.Ответы на вопрос
2)
uses crt;
const n=random(50);
var a:array[1..n]of integer;
i,min,max,s,k:integer;
begin
clrscr;min:=11;writeln('оценки ',n+1,' судей');
for i:=1 to n do
begin
a[i]:=random(10);
write(a[i],' ');
if a[i]> max then max:=a[i];
if a[i]<min then min:=a[i];
end;
for i:=1 to n do
begin
if (a[i]=min)or(a[i]=max) then begin write(i,' судья поставил минимальный или максимальный балл');writeln;end;
if (a[i]<>min)and(a[i]<>max) then begin s:=s+a[i];k:=k+1;end;
end;
writeln('среднее значение оценок судей ',(s/k):1:1);
end.
1)Uses crt;
const n=5;
Var a:array[1..n]of integer;
i,min,km:integer;
begin clrscr; randomize;
for i:=1 to n do
begin
a[i]:=Random(100);
write(a[i],' ');
end;
writeln;
min:=a[1];
km:=1;
for i:=2 to n do if a[i]<min then
begin
min:=a[i];
km:=i;
end;
writeln('Mimimalnoe chislo a[',km,']=',min);
min:=100;
km:=1;
for i:=2 to n do if (a[i]<min)and(a[i]mod 2=0) then
begin
min:=a[i];
km:=i;
end;
writeln('Naimenshee chetnoe cislo a[',km,']=',min);
readln;
end.
Для решения задачи нахождения минимального из четных элементов массива пяти целых чисел в Паскале, можно использовать следующий код:
pascalprogram MinEvenElement; const arraySize = 5; var arr: array[1..arraySize] of Integer; i, minEven: Integer; begin WriteLn('Введите ', arraySize, ' целых чисел:'); for i := 1 to arraySize do ReadLn(arr[i]); minEven := MaxInt; // Задаем начальное значение minEven как максимальное возможное число for i := 1 to arraySize do begin if (arr[i] mod 2 = 0) and (arr[i] < minEven) then minEven := arr[i]; end; if minEven <> MaxInt then WriteLn('Минимальный четный элемент массива: ', minEven) else WriteLn('В массиве нет четных элементов.'); end.
Для решения задачи по фигурному катанию, где необходимо найти средний балл, а также номера судей, поставивших наибольшую и наименьшую оценки, можно использовать следующий код:
pascalprogram FigureSkatingScores; const numOfJudges = 5; // Количество судей var scores: array[1..numOfJudges] of Real; i: Integer; minScore, maxScore, sumScores, avgScore: Real; minJudge, maxJudge: Integer; begin WriteLn('Введите оценки ', numOfJudges, ' судей:'); for i := 1 to numOfJudges do ReadLn(scores[i]); // Находим минимальную и максимальную оценки и соответствующих судей minScore := scores[1]; maxScore := scores[1]; minJudge := 1; maxJudge := 1; for i := 2 to numOfJudges do begin if scores[i] < minScore then begin minScore := scores[i]; minJudge := i; end; if scores[i] > maxScore then begin maxScore := scores[i]; maxJudge := i; end; end; // Находим сумму оценок для вычисления среднего балла sumScores := 0; for i := 1 to numOfJudges do sumScores := sumScores + scores[i]; // Вычисляем средний балл (сумма всех оценок - минимальная - максимальная) / (количество судей - 2) avgScore := (sumScores - minScore - maxScore) / (numOfJudges - 2); WriteLn('Средний балл: ', avgScore:0:2); WriteLn('Судей номер ', minJudge, ' и ', maxJudge, ' поставили наименьшую и наибольшую оценки соответственно.'); end.
Обратите внимание, что в коде для вычисления среднего балла используется формула, в которой отбрасываются наименьшая и наибольшая оценки.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
