Вопрос задан 20.07.2023 в 18:39. Предмет Информатика. Спрашивает Лей Валентин.

Написать программу, которая вычисляет среднее арифметическое ненулевых элементов введенного с

клавиатуры массива целых чисел. Ниже приведен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Введите элементы массива (10 целых чисел) в одной строке и нажмите .На паскале или на lazarus.-> 23 0 45 -5 12 0 -2 30 0 64 Сумма элементов массива: 184кол-во ненулевых элементов: 7Среднее арифметическое ненулевых элементов: 23.86
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кузьмина Елизавета.

var mas:array[1..10] of integer;

   i,kolvo:integer;

   b:real;

   

begin

writeln('Введите 10 целых чисел: ');

for i:=1 to 10 do

begin

read(mas[i]);

kolvo:= kolvo+1;

if (mas[i]=0) then kolvo:= kolvo-1;

end;

 

for i:=1 to 10 do  

begin

b:=mas[i] + b;

end;

 

b:= b/kolvo;

 

writeln('Количество ненулевых чисел= ', kolvo);

writeln('Среднее арифметическое ненулевых чисел= ', b);

 

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи, вам нужно создать программу, которая будет принимать ввод от пользователя, вычислять сумму ненулевых элементов, их количество и среднее арифметическое. Вот пример программы на языке Pascal:

pascal
program CalculateAverage; const ARRAY_SIZE = 10; var arr: array[1..ARRAY_SIZE] of Integer; i, count, sum, num: Integer; average: Real; begin // Ввод элементов массива WriteLn('Введите элементы массива (', ARRAY_SIZE, ' целых чисел) в одной строке:'); for i := 1 to ARRAY_SIZE do Read(arr[i]); // Вычисление суммы ненулевых элементов и их количества sum := 0; count := 0; for i := 1 to ARRAY_SIZE do begin if arr[i] <> 0 then begin sum := sum + arr[i]; count := count + 1; end; end; // Вычисление среднего арифметического ненулевых элементов if count > 0 then average := sum / count else average := 0; // Вывод результатов WriteLn('Сумма элементов массива: ', sum); WriteLn('Количество ненулевых элементов: ', count); WriteLn('Среднее арифметическое ненулевых элементов: ', average:0:2); end.

При запуске программы она попросит ввести 10 целых чисел в одной строке через пробел. После ввода выводятся сумма элементов массива, количество ненулевых элементов и среднее арифметическое ненулевых элементов. В приведенном примере результаты будут отображены в виде, аналогичном вашему примеру:

diff
Введите элементы массива (10 целых чисел) в одной строке: -> 23 0 45 -5 12 0 -2 30 0 64 Сумма элементов массива: 184 Количество ненулевых элементов: 7 Среднее арифметическое ненулевых элементов: 23.86

Этот код может быть скомпилирован и выполнен в среде Pascal (например, в Free Pascal) или в среде Lazarus.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос