Вопрос задан 06.03.2021 в 16:56.
Предмет Информатика.
Спрашивает Хрусталева Кристина.
ПОМОГИТЕ, ПОЖАЛУЙСТА! В Паскале. Написать программу, которая вычисляет среднее арифметическое
вводимой с клавиатуры последовательности действительных чисел. количество чисел должно задаваться во время работы программы. ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделено полу жирным шрифтом). вычисления среднего арифметического последовательности действительных чисел. найдите количество чисел последовательности ->15. введите последовательность. после ввода каждого числа нажмите enter. ->5.4 ->7.8 ->3.0 ->1.5 ->2.3 среднее арифметическое введенной последовательности: 4.00 Для завершения работы программы нажмите enter.Ответы на вопрос
Отвечает Ушакова Лилия.
Uses
Crt;
var
i,n:integer;
a,s:real;
begin
Writeln('Вычисление среднего арифметического');
Writeln('последовательности действительных чисел');
Write('Введите количество чисел последовательности ->');
Readln(n);
Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
s:=0;
for i:=1 to n do
begin
Read(a);
s:=s+a
end;
Writeln('Среднее арифметическое введенной последовательности: ',s/n);
Write('Для завершения работы программы нажмите Enter');
Readkey
end.
Тестовое решение:
Вычисление среднего арифметического
последовательности действительных чисел
Введите количество чисел последовательности ->5
Введите последовательность. После ввода каждого числа нажмите Enter
5.4
7.8
3.0
1.5
2.3
Среднее арифметическое введенной последовательности: 4
Для завершения работы программы нажмите Enter
Для версии Pascal.ABC.Net:
var
i,n:integer;
a,s:real;
begin
Writeln('Вычисление среднего арифметического');
Writeln('последовательности действительных чисел');
Write('Введите количество чисел последовательности ->');
Readln(n);
Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
s:=0;
for i:=1 to n do
begin
Read(a);
s:=s+a
end;
Writeln('Среднее арифметическое введенной последовательности: ',s/n)
end.
Crt;
var
i,n:integer;
a,s:real;
begin
Writeln('Вычисление среднего арифметического');
Writeln('последовательности действительных чисел');
Write('Введите количество чисел последовательности ->');
Readln(n);
Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
s:=0;
for i:=1 to n do
begin
Read(a);
s:=s+a
end;
Writeln('Среднее арифметическое введенной последовательности: ',s/n);
Write('Для завершения работы программы нажмите Enter');
Readkey
end.
Тестовое решение:
Вычисление среднего арифметического
последовательности действительных чисел
Введите количество чисел последовательности ->5
Введите последовательность. После ввода каждого числа нажмите Enter
5.4
7.8
3.0
1.5
2.3
Среднее арифметическое введенной последовательности: 4
Для завершения работы программы нажмите Enter
Для версии Pascal.ABC.Net:
var
i,n:integer;
a,s:real;
begin
Writeln('Вычисление среднего арифметического');
Writeln('последовательности действительных чисел');
Write('Введите количество чисел последовательности ->');
Readln(n);
Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
s:=0;
for i:=1 to n do
begin
Read(a);
s:=s+a
end;
Writeln('Среднее арифметическое введенной последовательности: ',s/n)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, который решает вашу задачу:
pascalprogram Среднее_арифметическое; var число, сумма: real; количество, счетчик: integer; begin количество := 0; сумма := 0; число := 0; writeln('Вычисление среднего арифметического последовательности действительных чисел.'); writeln('Найдите количество чисел последовательности -> '); readln(количество); writeln('Введите последовательность. После ввода каждого числа нажмите Enter.'); for счетчик := 1 to количество do begin readln(число); сумма := сумма + число; end; writeln('Среднее арифметическое введенной последовательности: ', сумма / количество:0:2); writeln('Для завершения работы программы нажмите Enter.'); readln; end.
После запуска программы она попросит вас ввести количество чисел последовательности. Введите 15, как вы указали в примере. Затем по очереди введите каждое число, нажимая Enter после каждого ввода. После ввода последнего числа программа вычислит и выведет среднее арифметическое введенной последовательности, а затем ожидает нажатия клавиши Enter для завершения работы.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
