
Вопрос задан 27.01.2021 в 03:22.
Предмет Информатика.
Спрашивает Коноплёв Август.
Написать программу (В ПАСКАЛЕ) , которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее
арифметическое.Рекомендуемый вид экрана во время работы программы приведен ниже. Данные, введенные пользователем выделены полужирным шрифтом.Вычисление среднего арифметического последовательности дробных чисел. После ввода каждого числа нажимайте . -> 5.4 ->7.8 -> 3.0 -> 1.5 -> 2.3 Среднее арифмитическое введенной последовательности: 4. 00 Для завершения работы программы нажмите < Enter>.

Ответы на вопрос

Отвечает Ворнаков Егор.
var i: integer;
var a : array[1..5] of real;
begin
for i in [1..5] do
begin
write('->');
readln(a[i]);
end;
writeln((a[1]+a[2]+a[3]+a[4]+a[5])/5:0:2);
end.



Отвечает Курявский Илья.
program dgh;
var
a,b: real;
i: integer;
Begin
b:=0;
for i:=1 to 5 do
begin
Write ('->'); readln (a);
b:=b+a;
end;
write('среднее арифметическое введенной последовательности:');
write (b/5:0:2);
Readln;
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili