Вопрос задан 20.07.2023 в 12:00.
Предмет Информатика.
Спрашивает Кузнецова Поля.
Составьте программу в паскале для нахождения суммы чисел кратных 7
Ответы на вопрос
Отвечает Онищук Мар'яна.
Ответ:
n - количество чисел
i - номер числа
s - сумма чисел

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы нахождения суммы чисел, кратных 7, в языке Pascal, можно использовать цикл и условное выражение. Вот пример программы:
pascalprogram SumOfMultiplesOfSeven; var number, sum: integer; begin sum := 0; writeln('Введите число (для завершения введите 0): '); readln(number); while number <> 0 do begin if number mod 7 = 0 then sum := sum + number; writeln('Введите число (для завершения введите 0): '); readln(number); end; writeln('Сумма чисел, кратных 7: ', sum); end.
Обратите внимание, что программа будет запрашивать числа у пользователя до тех пор, пока не будет введен ноль (0) - это будет сигналом остановки ввода. Введенные числа, кратные 7, будут добавляться в переменную sum, а затем, по завершении ввода, программа выведет итоговую сумму чисел, кратных 7.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
