Вопрос задан 19.07.2023 в 20:08.
Предмет Информатика.
Спрашивает Костикова Лиза.
Программирование Pascal: Массив нужно заполнить вводом с клавиатуры. Дан целочисленный массив из
30 элементов. Элементы массива могут принимать целые значения от 0 до 100 – баллы учащихся выпускного класса, полученные на экзамене по информатике. Напишите программу, которая позволяет найти и вывести количество учащихся, чьи баллы на экзамене выше среднего балла по классу.Ответы на вопрос
Отвечает Бейфус Маша.
Ответ:
Объяснение:
var
a:array [1..30] of integer;
i,s:integer;
r:real;
begin
writeln('Введите оценки учащихся(значения от 0 до 100)');
s:=0;
for i:=1 to 30 do
begin
readln(a[i]);
s:=s+a[i];
end;
r:=s/30;
writeln('средний бал=',r:4:2);
s:=0;
for i:=1 to 30 do
if a[i]>r then s:=s+1;
writeln('Количество учащихся с оценками выше среднего=',s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения данной задачи на заполнение и анализ массива баллов учащихся, и последующего поиска количества учащихся, чьи баллы выше среднего, можно написать программу на языке Pascal. Вот пример такой программы:
pascalprogram CountAboveAverage; const MAX_STUDENTS = 30; var scores: array[1..MAX_STUDENTS] of Integer; sum, average: Real; aboveAverageCount, i: Integer; begin // Ввод баллов учащихся с клавиатуры Writeln('Введите баллы учащихся (от 0 до 100):'); for i := 1 to MAX_STUDENTS do begin Write('Балл учащегося ', i, ': '); ReadLn(scores[i]); // Проверка, чтобы баллы находились в допустимом диапазоне while (scores[i] < 0) or (scores[i] > 100) do begin WriteLn('Ошибка: Балл должен быть от 0 до 100.'); Write('Попробуйте еще раз: '); ReadLn(scores[i]); end; // Подсчет суммы баллов для нахождения среднего значения sum := sum + scores[i]; end; // Вычисление среднего балла average := sum / MAX_STUDENTS; // Подсчет количества учащихся с баллами выше среднего aboveAverageCount := 0; for i := 1 to MAX_STUDENTS do begin if scores[i] > average then Inc(aboveAverageCount); end; // Вывод результата Writeln('Средний балл по классу: ', average:0:2); Writeln('Количество учащихся с баллами выше среднего: ', aboveAverageCount); end.
Программа позволяет пользователю ввести баллы для каждого учащегося, после чего рассчитывает средний балл по классу и выводит количество учащихся, чьи баллы выше среднего.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
