Вопрос задан 18.07.2023 в 02:16.
Предмет Информатика.
Спрашивает Кузнецова Софья.
1 задание)Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения
от –10 000 до 10 000 включительно. Написать программу, позволяющую найти и вывести количество пар элементов массива, сумма которых нечётна и положительна. Под парой подразумевается два подряд идущих элемента массива. Язык Pascal 2 задание) Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 10 000 включительно. Написать программу, которая подсчитывает сумму первых цифр двузначных нечётных элементов, а затем заменяет каждый двузначный нечётный элемент на число, равное найденной сумме. Гарантируется, что в массиве есть хотя бы один двузначный нечётный элемент. В качестве результата необходимо вывести сначала вторую половину массива, а затем первую. Например, для массива из восьми элементов:7 15 9 333 22 71 14 95программа должна получить массив7 17 9 333 22 17 14 17и вывести числа: 22 17 14 17 7 17 9 333 язык PascalОтветы на вопрос
Отвечает Жусупов Чингиз.
Ответ:
program ArrayTest;
var
a: array [1..20] of Integer;
i, s, c: Integer;
begin
Randomize;
for i := Low (a) to High (a) do begin
a [i] := Random (20001) - 10000;
Write (a [i], ' ');
end;
c := 0;
WriteLn;
for i := Low (a) to High (a) - 1 do begin
s := a [i] + a [i + 1];
if (s mod 2 <> 0) and (s > 0) then begin
Inc (c);
WriteLn (a [i], ' ', a [i + 1]);
end;
end;
WriteLn ('Количество пар элементов = ', c);
ReadLn;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
1 задание на языке Pascal:
pascalprogram CountOddPositivePairs; var arr: array[1..20] of Integer; count: Integer; i: Integer; begin count := 0; // Ввод элементов массива for i := 1 to 20 do begin Write('Введите элемент массива arr[', i, ']: '); ReadLn(arr[i]); end; // Подсчет количества пар for i := 1 to 19 do begin if (arr[i] + arr[i+1]) mod 2 = 1 then if arr[i] + arr[i+1] > 0 then count := count + 1; end; // Вывод результата WriteLn('Количество пар элементов сумма которых нечётна и положительна: ', count); end.
2 задание на языке Pascal:
pascalprogram ReplaceAndPrintArray; var arr: array[1..30] of Integer; i: Integer; sum: Integer; begin // Ввод элементов массива for i := 1 to 30 do begin Write('Введите элемент массива arr[', i, ']: '); ReadLn(arr[i]); end; // Подсчет суммы первых цифр двузначных нечетных элементов sum := 0; for i := 1 to 30 do begin if (arr[i] >= 10) and (arr[i] <= 99) and (arr[i] mod 2 = 1) then sum := sum + (arr[i] div 10); end; // Замена двузначных нечетных элементов на сумму for i := 1 to 30 do begin if (arr[i] >= 10) and (arr[i] <= 99) and (arr[i] mod 2 = 1) then arr[i] := sum; end; // Вывод второй половины массива for i := 16 to 30 do Write(arr[i], ' '); // Вывод первой половины массива for i := 1 to 15 do Write(arr[i], ' '); end.
Обратите внимание, что в обоих заданиях использовано предположение, что пользователь вводит числа в корректном формате. Проверка на корректность ввода не реализована в этих примерах.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
