Паскаль Дан возраст человека в годах (0..99 лет). Написать программу, которая называет возраст
по-русски. Например: если ввести «1», то программа должна выдать - «1 год», если ввести «22», то программа должна выдать - «22 года», если ввести «45», то программа должна выдать - «45 лет», и так для каждого числа в диапазоне от 0 до 99. Разрешается использовать в программе не более 5 операторов IF.Ответы на вопрос
Program vozrast;
var x,y : integer;
var godik: string;
Begin
readln(x);
y:=x mod 10;
if (y=0) or (y>=5) then godik:='Лет';
if (y=1) then godik:='Год';
if (y>=2) and (y<=4) then godik:='Года';
if (x>=11) and (x<=14) then godik:='Лет';
writeln(x,' ',godik);
End.
program gg;
var e:integer;
begin
writeln ('Введите возраст');
read (e);
if e > 99 then
writeln ('Введите возраст до 99 лет')
else if (e mod 10 = 1) and (e <> 11) then
writeln (e,' год')
else if (e >= 2) and (e <= 4) or (e mod 10 = 2) or (e mod 10 = 3) or (e mod 10 = 4) then
writeln (e,' года')
else if (e >= 5) and (e <= 150) then
writeln (e,' лет')
end.
Для решения этой задачи можно использовать математические и логические операции, чтобы определить правильное склонение слова "год" в зависимости от возраста. Вот пример программы на языке Паскаль:
pascalprogram AgeInRussian; var age: integer; lastDigit: integer; begin // Ввод возраста writeln('Введите возраст (0..99): '); readln(age); // Определение последней цифры возраста lastDigit := age mod 10; // Вывод возраста с правильным склонением writeln('Возраст: ', age, ' ', case lastDigit of 1: 'год'; 2, 3, 4: 'года'; else 'лет'; end); end.
Эта программа использует оператор case для выбора правильного склонения слова "год" в зависимости от последней цифры возраста. Если последняя цифра - 1, то используется "год", если 2, 3 или 4 - "года", иначе - "лет". Таким образом, программа позволяет правильно склонять слово для любого числа в диапазоне от 0 до 99.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
