Срочно!!!!!!!!!!!!!!! Языки: Java,Python,C++НЕЛЬЗЯ использовать ветвления и циклы!!!!!!!!!!!!!!На
вход программе подаются два целых числа n и m, каждое в отдельной строке 0 < n ≤ 12, 0 ≤ m < 60, указывающие момент времени "n часов m минут". Определите наименьшее число полных минут, которое должно пройти до того момента, когда часовая и минутная стрелки ни циферблате совпадут, не обязательно на каком-то делении. Вещественную арифметику не использовать.Ответы на вопрос
Ответ:
n = int(input())
m = int(input())
print(60*(n + 1 //(1 + (60*n + 1) //(11*m + 1))*12) // 11 - m)
Объяснение:
Для решения данной задачи без использования ветвлений и циклов можно воспользоваться математическим подходом и формулами.
Для начала, определим формулу, которая вычисляет количество минут, через которое часовая стрелка пройдет полный круг (12 часов). Это значение можно вычислить как 720 минут.
Затем, определим формулу, которая вычисляет количество минут, через которое минутная стрелка пройдет полный круг (60 минут). Это значение равно 60 минут.
Теперь, чтобы найти наименьшее число полных минут до того момента, когда часовая и минутная стрелки совпадут, рассмотрим следующий алгоритм:
Переведем часы в минуты и сложим с минутами:
total_minutes = n * 60 + m.Вычислим остаток от деления
total_minutesна720(количество минут для полного круга часовой стрелки):hour_hand_position = total_minutes % 720.Найдем разность между количеством минут для полного круга минутной стрелки и
hour_hand_position:difference = 60 - hour_hand_position.В итоге, значение
differenceи будет ответом на задачу, так как это наименьшее число полных минут до совпадения стрелок.
Вот Java-код, реализующий данный алгоритм:
javaimport java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int n = scanner.nextInt();
int m = scanner.nextInt();
int total_minutes = n * 60 + m;
int hour_hand_position = total_minutes % 720;
int difference = 60 - hour_hand_position;
System.out.println(difference);
}
}
Заметьте, что этот код не содержит ветвлений и циклов, и использует только простые арифметические операции для вычисления ответа на задачу.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
