Вопрос задан 13.07.2023 в 12:26. Предмет Информатика. Спрашивает Романовских Юля.

50 баллов! Составить программу, которая запрашивает пароль (трехзначное число + 2 символа) до тех

пор, пока он не будет правильно введен. Верный пароль должен быть задан в виде константы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Соболь Вика.

Ответ:

PASSWORD = '123qw'

while True:

   password = input('Введите пароль: \n>> ')

   if password == PASSWORD:

       print('Пароль совпадает!')

       break

   else:

       print('Пароль введен неверно!\n')

Объяснение:

Python 3.8.2

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Хорошо! Ниже представлена простая программа на языке Python, которая запрашивает у пользователя пароль до тех пор, пока он не будет правильно введен. Верный пароль задан в виде константы VERIFIED_PASSWORD.

python
VERIFIED_PASSWORD = "123ab" # Здесь задается верный пароль while True: user_input = input("Введите пароль (трехзначное число + 2 символа): ") if user_input == VERIFIED_PASSWORD: print("Пароль верный! Доступ разрешен.") break else: print("Пароль неверный. Попробуйте еще раз.")

Обратите внимание, что данная программа предполагает, что пользователь вводит пароль в правильном формате - трехзначное число + 2 символа. Если нужны более сложные проверки на формат пароля, можно использовать регулярные выражения или добавить дополнительные проверки в коде.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос