Вопрос задан 10.07.2023 в 07:25. Предмет Информатика. Спрашивает Полянская Екатерина.

Срочнооо ребят!!! Напишите программу, которая в последовательности целых чисел определяет

количество отрицательных чисел и сумму положительных. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: количество отрицательных чисел и сумму положительных.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кинжебаев Фаиль.

# Python 3.x

# sequence - данная нам последовательность чисел

odds=int()

sumary=int()

for digit in sequence:

   if digit == 0: break

   if digit % 2 == 0: sumary=sumary + digit

   else: odds=odds + 1

print("Sumary: ", sumary)

print("Odds amount: ", odds)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая выполняет указанные действия:

python
negative_count = 0 positive_sum = 0 while True: num = int(input("Введите целое число (для завершения введите 0): ")) if num == 0: break if num < 0: negative_count += 1 else: positive_sum += num print("Количество отрицательных чисел:", negative_count) print("Сумма положительных чисел:", positive_sum)

Скопируйте этот код в файл с расширением .py и запустите его. Программа будет запрашивать целые числа до тех пор, пока не будет введено число 0. После ввода 0 программа выведет количество отрицательных чисел и сумму положительных чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос