
Вопрос задан 09.07.2023 в 20:56.
Предмет Информатика.
Спрашивает Голибов Парвиз.
написать программу на языке программирования в среде разработки Pascal. Ввести три числа, если они
отрицательные(каждое, но не одновременно) , то напечатать их модули, иначе их квадраты

Ответы на вопрос

Отвечает Ким Илья.
Также прикрепляю код во вложении.
===PascalABC.Net===
program brainly;
var
num1, num2, num3 :integer;
begin
Write('Введите три числа: ');
ReadLn(num1, num2, num3);
Write('Первое число: ');
if num1 < 0 then
WriteLn(abs(num1))
else WriteLn(sqr(num1));
Write('Второе число: ');
if num2 < 0 then
WriteLn(abs(num2))
else WriteLn(sqr(num2));
Write('Третье число: ');
if num3 < 0 then
Write(abs(num3))
else Write(sqr(num3));
end.




Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке программирования Pascal, который выполняет указанное условие:
pascalprogram PositiveOrNegative; var num1, num2, num3: real; begin writeln('Введите три числа:'); readln(num1, num2, num3); if (num1 < 0) and (num2 >= 0) and (num3 >= 0) then begin writeln('Модуль первого числа:', abs(num1)); writeln('Второе и третье числа положительные, поэтому их квадраты не будут выведены.'); end else if (num1 >= 0) and (num2 < 0) and (num3 >= 0) then begin writeln('Второе числа отрицательное, его модуль:', abs(num2)); writeln('Первое и третье числа положительные, поэтому их квадраты не будут выведены.'); end else if (num1 >= 0) and (num2 >= 0) and (num3 < 0) then begin writeln('Третье числа отрицательное, его модуль:', abs(num3)); writeln('Первое и второе числа положительные, поэтому их квадраты не будут выведены.'); end else begin writeln('Все три числа отрицательные или все три числа положительные.'); writeln('Квадраты чисел:'); writeln('Первое число:', num1*num1); writeln('Второе число:', num2*num2); writeln('Третье число:', num3*num3); end; end.
Это пример программы, которая читает три числа и выполняет указанные условия в соответствии с задачей. Вы можете скопировать этот код в среду разработки Pascal и выполнить его там.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 562

Информатика 404

Информатика 31

Информатика 76

Информатика 16

Информатика 41

Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili