Вопрос задан 07.07.2023 в 11:10.
Предмет Информатика.
Спрашивает Савин Дмитрий.
ДАЮ 23 БАЛЛОВ!♥️Напишите программу для нахождения добутку цыфр натурального числа N (ПАСКАЛЬ)
СРОЧНО, ПОЖАЛУЙСТА ♥️Ответы на вопрос
Отвечает Мамчур Мария.
Ответ:
- var p, n: integer;
- begin
- readln(n);
- p := 1;
- while n <> 0 do
- begin
- if (n mod 10)<>0 then p := p * (n mod 10);
- n := n div 10;
- end;
- writeln(p);
- end.
Пример работоспособности:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль для нахождения произведения цифр натурального числа N:
pascalprogram ProductOfDigits; var N, digit, product: Integer; begin writeln('Введите натуральное число N:'); readln(N); product := 1; while N > 0 do begin digit := N mod 10; product := product * digit; N := N div 10; end; writeln('Произведение цифр числа: ', product); end.
Вы можете скопировать этот код в среду программирования Pascal, скомпилировать и запустить его. Программа попросит вас ввести натуральное число N, а затем выведет произведение его цифр.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
