
Вопрос задан 11.07.2018 в 03:22.
Предмет Информатика.
Спрашивает Правосуд Богдан.
Помогите, пожалуйста Напишите эффективную программу, которая по двум данным натуральным числам a и
b, не превосходящим 30000, подсчитывает количество нечетных натуральных чисел на отрезке [a,b] (включая концы отрезка). Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1 ≤ a ≤ b ≤ 30000. Проверять входные данные на корректность не нужно. Программа должна вывести одно число: количество нечетных чисел на отрезке [a,b]. Пример работы программы: Входные данные: 11, 21 Выходные данные: 6

Ответы на вопрос

Отвечает Орёл Евгений.
Var a,b,n: integer;
begin
write('a b через пробел: '); readln(a,b);
n:=b-a+1;
if (n mod 2 = 1) and (a mod 2 = 1) then
n:=n div 2 + 1
else n:= n div 2;
writeln('число нечетных чисел: ',n);
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili