Вопрос задан 05.07.2023 в 17:25. Предмет Информатика. Спрашивает Мацунова Дана.

Написать программу, которая находит площадь треугольника по формуле. С использованием делегатов

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Калугина Диана.

using System;

namespace kp9p_pr_10_zad_6

{

   class Program

   {

       delegate void Square(double a1, double b1, double alfa1);

       static void Main(string[] args)

       {

           double a, b; // переменные для сторон a и b  

           double alpha; // переменная для угла альфа  

           Console.WriteLine("Введите значения треугольника:\n ");

           Console.Write("a: ");

           a = double.Parse(Console.ReadLine());   // ввод стороны a  

           Console.Write("b: ");

           b = double.Parse(Console.ReadLine()); // ввод стороны b  

           Console.Write("Угол альфа: ");

           alpha = double.Parse(Console.ReadLine()); // ввод угла альфа  

           sq(a, b, alpha);  

           static void sq(double a1, double b1, double alpha1) // функция sq расчета и вывода площади  

           {

               Console.WriteLine("\nПлощадь: {0}", (a1 * b1 * Math.Sin(alpha1)) / 2); // вывод и расчет площади  

           }

       }

   }

}  

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке C#, которая находит площадь треугольника с использованием делегата:

csharp
using System; namespace TriangleAreaCalculator { // Определение делегата для функции, вычисляющей площадь треугольника delegate double TriangleAreaDelegate(double a, double b, double c); class Program { static void Main(string[] args) { Console.WriteLine("Введите длины сторон треугольника:"); Console.Write("Сторона a: "); double a = double.Parse(Console.ReadLine()); Console.Write("Сторона b: "); double b = double.Parse(Console.ReadLine()); Console.Write("Сторона c: "); double c = double.Parse(Console.ReadLine()); // Создание экземпляра делегата и привязка к функции для вычисления площади треугольника TriangleAreaDelegate calculateArea = CalculateTriangleArea; // Вызов делегата для вычисления площади double area = calculateArea(a, b, c); Console.WriteLine($"Площадь треугольника: {area}"); } // Функция для вычисления площади треугольника по формуле Герона static double CalculateTriangleArea(double a, double b, double c) { double s = (a + b + c) / 2; double area = Math.Sqrt(s * (s - a) * (s - b) * (s - c)); return area; } } }

В этой программе определен делегат TriangleAreaDelegate, который используется для связи с функцией CalculateTriangleArea. Пользователь вводит длины сторон треугольника, а затем программа вызывает делегат, который вызывает функцию CalculateTriangleArea для вычисления площади треугольника.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос