Вопрос задан 05.07.2023 в 02:19. Предмет Информатика. Спрашивает Смирнов Евгений.

Язык python. Поменять местами две диагонали. Дан квадратный массив. Поменяйте местами в каждом

столбце элементы, стоящие на главной и побочной диагонали. Входные данные В первой строке дано число n≤10. Далее идут n строк по n неотрицательных целых чисел не больше 100. Выходные данные Ответ на задачу. Примеры Ввод 3 1 2 3 4 5 6 7 8 9 Вывод 7 2 9 4 5 6 1 8 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Горбык Вова.

n = int(input())

arr = [[int(elem) for elem in input().split()] for i in range(n)]

for i in range(n):

   arr[i][i], arr[n-i-1][i] = arr[n-i-1][i], arr[i][i]

for i in range(n):

   print(*arr[i])

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете решить эту задачу, используя язык Python. Вот пример решения:

python
def swap_diagonals(matrix): n = len(matrix) for i in range(n): matrix[i][i], matrix[i][n-i-1] = matrix[i][n-i-1], matrix[i][i] return matrix # Пример ввода данных n = int(input()) matrix = [] for _ in range(n): row = list(map(int, input().split())) matrix.append(row) # Вызов функции для обмена диагоналей swapped_matrix = swap_diagonals(matrix) # Вывод результата for row in swapped_matrix: print(*row)

Этот код считывает входные данные, вызывает функцию swap_diagonals() для обмена диагоналей в матрице, а затем выводит результат. Функция swap_diagonals() проходит по каждой строке матрицы и меняет местами элементы на главной и побочной диагонали.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос